RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   Airtronics Support Forum (https://www.rcuniverse.com/forum/airtronics-support-forum-516/)
-   -   Dual Battery Issues (https://www.rcuniverse.com/forum/airtronics-support-forum-516/9963166-dual-battery-issues.html)

skysfallin 08-27-2010 09:06 AM

Dual Battery Issues
 
I am trying to hook up two batteries and two switches to my Airtronics 10 channel reciever. They are hooked up as the diagram shows and when they are turned on the reciever will not activate. When they are turned using only one battery at a time it will activate. This reciever has two battery inputs. Am
I doing something wrong or do I have to run both of them through a Y harness? Sorry I can't get the picture to load, but they run from the batts to the swithes to the receiver. I appreciate any help.

FarrellF 08-27-2010 09:28 AM

RE: Dual Battery Issues
 
The 10ch (and other) receivers can use two batteries, with or without a y-harness. Make sure you have both switches plugged in correctly. If you aren't able to post a photo here you could try one of the free photo services like flickr.com

-Farrell

DKMILLETTE 08-28-2010 09:18 AM

RE: Dual Battery Issues
 
Double check the polarity at the plugs in the receiver

skysfallin 08-28-2010 07:44 PM

RE: Dual Battery Issues
 
As soon as it did not work I rechecked all the connections and plugs. Both batteries will work if they are switched on one at a time, meaning either or but not both. I don't understand why when they are both turned on the reciever doesn't work. It's flippin me out.


All times are GMT -8. The time now is 12:02 AM.


Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.