Go Back  RCU Forums > Electric Aircraft Universe > Ask the Expert Sal - Electric Airplane Advice
Reload this Page >

E-Flight 160 motor/Castle Phoenix Ice HV 120

Notices
Ask the Expert Sal - Electric Airplane Advice Here is your chance to ASK SAL, the expert for all your electric flight related questions. If you are not Sal, please do not answer questions in this forum.

E-Flight 160 motor/Castle Phoenix Ice HV 120

Old 10-23-2019, 07:37 AM
  #1  
LA7flier
Thread Starter
My Feedback: (1)
 
Join Date: Oct 2002
Location: Sedona, AZ
Posts: 495
Likes: 0
Received 0 Likes on 0 Posts
Default E-Flight 160 motor/Castle Phoenix Ice HV 120

Im having a tough time with this motor esc combo....I have run this many times in the past but now I am getting a motor "growl" with forward/reverse and "grinding" as I increase throttle. I am using 2 6S 6600 MaH packs in parallel. I have updated the Castle firmware to current version and reset all the ESC to factory default. Nothing. The ESC is not damaged,,,before I send this back to Castle, maybe there is something I have overlooked?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.