Go Back  RCU Forums > Radios, Batteries, Clubhouse and more > Batteries & Chargers
Reload this Page >

Redcat Blackout XTE with 2s Lipo

Notices
Batteries & Chargers Nicads, Nickel Metal Hydride, Lithium, LiPoly, Chargers, Cyclers, etc...

Redcat Blackout XTE with 2s Lipo

Old 02-16-2020, 06:07 AM
  #1  
scdlguy
Junior Member
Thread Starter
 
Join Date: Feb 2020
Posts: 3
Received 0 Likes on 0 Posts
Default Redcat Blackout XTE with 2s Lipo

Installed a 2s 80c 6200mah Lipo, and moved lvc jumper. Truck went like a bat out of hell, but had less run-time than to about the same as the 3000mah NiMH that came with the trucks. I was under the impression id get at least double the run-time, but only had about half the original.
Old 02-16-2020, 11:08 AM
  #2  
RustyUs
 
RustyUs's Avatar
 
Join Date: Oct 2012
Location: central PA
Posts: 4,573
Received 5 Likes on 5 Posts
Default

That's a pretty large capacity battery. Depending on motor, gearing, setup, and terrain, I would think you should get at least 20 minutes of run time on your Blackout.
Old 02-17-2020, 04:06 AM
  #3  
scdlguy
Junior Member
Thread Starter
 
Join Date: Feb 2020
Posts: 3
Received 0 Likes on 0 Posts
Default

Thanks. Thatís about the run time I had. Problem/question is thatís also the same run time I had with the stock 3000 Nimh battery.
shouldnt I of had at least double going to a 6200 2s Lipo?

vr
Old 02-18-2020, 10:55 AM
  #4  
ryan_t888
 
ryan_t888's Avatar
 
Join Date: Jul 2005
Location: Hamilton, ON, CANADA
Posts: 5,518
Likes: 0
Received 6 Likes on 6 Posts
Default

Hello scdlguy,

Do you know how many mAh your charger is putting back in to the battery when you charge it again?


It sounds like the LiPo upgrade in your case allows the car to accelerate much more aggressively. This doesn't come for free. I would imagine that your motor is drawing more power then it had ever drawn with the NiMh battery pack.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.