Go Back  RCU Forums > Radios, Batteries, Clubhouse and more > Batteries & Chargers
Reload this Page >

icharger 4010 back from the dead

Notices
Batteries & Chargers Nicads, Nickel Metal Hydride, Lithium, LiPoly, Chargers, Cyclers, etc...

icharger 4010 back from the dead

Old 10-19-2022, 06:03 PM
  #1  
Srbell
Junior Member
Thread Starter
 
Join Date: Oct 2020
Posts: 13
Likes: 0
Received 1 Like on 1 Post
Default icharger 4010 back from the dead

Anyone tried fixing a icharger 4010 duo? I had a power supply go from 36v the 24v while charging. Supposedly a sudden drop in voltage will fry your charger, and it did😂. So I replaced almost all the 3606G mosfetís along with a few 3205 fets. A few issues, but it works except it wonít charge on channel 2. Everything on ch1 works, ch2 will balance and discharge but not charge. Itís making a clicking sound while actually show a negative charge current. This is a current limited supply Iíve hooked it up to. If you try a regular psu ( I did), you get to replace more mosfetís! Any ideas?


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.