Go Back  RCU Forums > RC Airplanes > Beginners
Reload this Page >

HZ Firebird Stratos not binding!

Notices
Beginners Beginners in RC start here for help.

HZ Firebird Stratos not binding!

Old 04-17-2017, 09:05 PM
  #1  
jimbyjoe
Senior Member
Thread Starter
 
Join Date: Feb 2006
Location: BrisbaneQueensland, AUSTRALIA
Posts: 438
Likes: 0
Received 0 Likes on 0 Posts
Default HZ Firebird Stratos not binding!

Hi guys

I should know better but can't figure this out....Got a used Stratos with no TX, bought a new TX and a new LiPo. Have gone to bind as per manual, and can't get it to. This is what happens:

Connect battery -> ESC light flashes fast about 17 times, then stops and the servos twitch once. After about 5 seconds the ESC light flashes rapidly and can't get any sense out of it.
When I turn the TX on it beeps twice, then the TX light repeatedly flashes slowly. When I do the binding per manual and turn the TX on whilst holding left, it just beeps repeatedly.
So not sure if the new TX is stuffed, my new LiPo is stuffed, or the ESC is! Or if it's just one of these tricky ones to bind. Don't want to spend much more on this as it's costing heaps already.
Cheers
j
Old 04-17-2017, 10:07 PM
  #2  
NEW222
 
Join Date: Sep 2004
Location: OAKBANK, MB, CANADA
Posts: 361
Likes: 0
Received 1 Like on 1 Post
Default

What kind of Tx did you buy?
Old 04-18-2017, 12:09 AM
  #3  
jimbyjoe
Senior Member
Thread Starter
 
Join Date: Feb 2006
Location: BrisbaneQueensland, AUSTRALIA
Posts: 438
Likes: 0
Received 0 Likes on 0 Posts
Default

The genuine replacement one, in Mode 1. I'm in Australia but I bought the plane off a bloke in my city and the transmitter also came from here. There's not slight frequency variations between countries are there?
Old 04-18-2017, 05:38 PM
  #4  
jimbyjoe
Senior Member
Thread Starter
 
Join Date: Feb 2006
Location: BrisbaneQueensland, AUSTRALIA
Posts: 438
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by NEW222 View Post
What kind of Tx did you buy?


The original as above, sorry didn't quote.

BTW I just checked the LiPo voltage and it's fully charged so it's not that.....

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.