Notices
Brushed/Brushless motors, speed controls, gear drives Discuss all aspects of brushless motors, brushed motors, speed controls (ESC's), gear drives and propellers in this forum.

Esc, Help

Old 08-04-2003, 04:35 AM
  #1  
grtdane
Junior Member
Thread Starter
 
Join Date: Aug 2003
Location: LA, CA
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Esc, Help

I am using a old Ace speed controller with an Astro Cobalt 25 geared, using a 14 cell NI mh pack putting 18 to 20 V into the ESC but only able to get 13 to 14 V out of the ESC to the motor at WOT. all connections are in good shape and the ESC is not getting hot. Anyone have any ideas as to why?

Is the ESC on its way out?

Grtdane
Old 08-08-2003, 06:20 PM
  #2  
Greg Covey
Senior Member
 
Greg Covey's Avatar
 
Join Date: May 2003
Location: Rochester, NY
Posts: 5,710
Likes: 0
Received 2 Likes on 2 Posts
Default Esc, Help

This sounds like a typical "loaded" to "unloaded" voltage scenario.

What are the cells that you are using?

Can you measure the current somehow?

What size prop are you using on your 14-cell setup?

We can guestimate the current draw from the cell count and prop size so if you can't measure the current...that is ok.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.