Notices
Brushed/Brushless motors, speed controls, gear drives Discuss all aspects of brushless motors, brushed motors, speed controls (ESC's), gear drives and propellers in this forum.

Help-ESC Problem

Old 07-28-2014, 06:04 PM
  #1  
EZ Fly
Junior Member
Thread Starter
 
Join Date: Jun 2007
Location: Arlington, WA
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Angry Help-ESC Problem

I hope somebody out there can help me out here.

I have a Super Tigre 30 amp ESC that won't arm properly. When I hook up to a fully charged 3s battery, it gives me a continuous Beep-Beep-Beep sound, instead of the normal Safe Arming sequence. End result of course, is no throttle control, however all other controls on the plane work fine.

Does anyone know what the continuous Beep is trying to tell me? Nothing in the instructions about it.

Thanks
Old 07-29-2014, 03:27 AM
  #2  
aymodeler
My Feedback: (3)
 
aymodeler's Avatar
 
Join Date: Feb 2010
Location: Connecticut
Posts: 468
Likes: 0
Received 4 Likes on 2 Posts
Default

I'm guessing you already checked both of these things, but they both happened to me at one time or another, so I thought I would throw them out ...

1) Is your throttle reversed on your transmitter?

2) Is your throttle trim bumped? This one had me going for the better part of an afternoon, I could not get the ESC to work and I checked and rechecked everything I could think of (I even swapped out receivers). I finally noticed that the trim setting on my transmitter was bumped off center, so that even though the throttle was fully back, the ESC was getting a throttle command and the safety kicked in preventing it from arming. Man did I feel stupid!
Old 07-29-2014, 11:21 AM
  #3  
EZ Fly
Junior Member
Thread Starter
 
Join Date: Jun 2007
Location: Arlington, WA
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by aymodeler View Post
I'm guessing you already checked both of these things, but they both happened to me at one time or another, so I thought I would throw them out ...

1) Is your throttle reversed on your transmitter?

2) Is your throttle trim bumped? This one had me going for the better part of an afternoon, I could not get the ESC to work and I checked and rechecked everything I could think of (I even swapped out receivers). I finally noticed that the trim setting on my transmitter was bumped off center, so that even though the throttle was fully back, the ESC was getting a throttle command and the safety kicked in preventing it from arming. Man did I feel stupid!
Thanks for your reply. Yes, I double checked the throttle trim at neutral and the throttle channel is reversed (needed for a Futaba xmtr) This is the wierd part; after double checking these items I made two other changes on the xmtr (adjusted the EPA to 100% and took the Throttle Cut Off, off of a switch, which was already Inhibited) and tried it this morning and it armed correctly. My guess is the end point adjustment was the culprit. This a replacement ESC sent to me under warranty. The original checked out properly at home but when I got to the flying field, the beeping started. Don't understand any of this, but for now it seems to work properly. will have to get to the field and see if I can fly it. Thanks again for the help.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.