Notices
Brushed/Brushless motors, speed controls, gear drives Discuss all aspects of brushless motors, brushed motors, speed controls (ESC's), gear drives and propellers in this forum.

480 outrunner problems???

Old 06-27-2015, 06:25 AM
  #1  
oxen
Thread Starter
 
Join Date: Dec 2006
Location: santa rosa, CA
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
Question 480 outrunner problems???

I was flying my Sorceress 57" span EPO electric recently and just cruising along
in level flight when the Suppo 480 engine fell out of the plane. Upon landing I
noticed that motor mount had given way leaving only the four screws to the firewall
and maybe 3/8" of the motor mount under each screw. Dangling from the plane
was the center part of the motor containing the magnets and the other part of the
motor mount - truly a strange occurrence! Unable to find the rest of the engine
and the cowl, prop, etc. I was going to chalk this up to poor metal quality and let
it go, but now I'm curious to know if anyone has ever experienced anything similar
to this or has any input as to the cause? I'd flown the motor in several other planes
without a problem. Many thanks.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.