Notices
Brushed/Brushless motors, speed controls, gear drives Discuss all aspects of brushless motors, brushed motors, speed controls (ESC's), gear drives and propellers in this forum.

Raiden Motor Question - please help

Old 04-18-2009, 08:47 AM
  #1  
mrgv
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: hialeah, FL
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Raiden Motor Question - please help

Hi, I am new to the hobby and have I recently purchased a Riaden Brushless Motor 400 - 1300 kv on line. The problem is that after I installed the motor it worked just fine. However, when I put on the propeller the motor cuts off. It stops completely. Also, without a propeller, the motor stops when I put any kind of pressure on it with my finger. In other words, every time the motor has resistance applied to it, it cuts off.

Does anybody know why it’s doing this? I'm I doing something wrong, or is the motor no good.

Thank you
Old 04-18-2009, 10:38 AM
  #2  
BigTb17
Senior Member
 
Join Date: Feb 2008
Location: Perrysburg, OH
Posts: 1,167
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Raiden Motor Question - please help

What speed control and battery are you using? Does anything get hot, any strange noises, etc.? When it stops, is there any indication that it is still trying to spin, or does it simply stop as if you shut it off?

Also, what size prop are you using? Does it spin it at all? For instance, does it start spinning but once the throttle gets above a certain point it shuts off? Or does it not spin at all?
Old 04-18-2009, 12:32 PM
  #3  
mrgv
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: hialeah, FL
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Raiden Motor Question - please help

I'm using an Electricfly ss 35 silver series esc.; Fusion 11.1 vol 1500aAh 15C lipo battery from nitroplanes.com with 9 x 6 prop. Nothing gets hot. The prop spins, but as soon as it gets past about 1/4 throttle, the motor shuts off, but its still trying to spin. It makes a noise like its trying to spin, but something is holding it back, it sounds like a clicking sound.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.