Notices
Brushed/Brushless motors, speed controls, gear drives Discuss all aspects of brushless motors, brushed motors, speed controls (ESC's), gear drives and propellers in this forum.

Receiver glitch at 9 amps

Old 05-27-2009, 05:42 PM
  #1  
DaveFlynn
Senior Member
Thread Starter
 
Join Date: Feb 2007
Location: Arcadia, CA
Posts: 450
Likes: 0
Received 0 Likes on 0 Posts
Default Receiver glitch at 9 amps

My latest plane is yet to fly, every time it is fullyassembledthe motor would rev up. Here's the setup: 7xHS5645MG servos, Berg 7 Rx, Castle HV-45 ESC with eLogger V3 and Glow-Emulator(amp limit), 5 cell 2300mAH 6v Rx battery, 12S1P 2100mAH flight batt, KMS 5331/10 250Kv motor. This is the first time I've used more than 4 servos in a plane. I've played musical-servos for two days, and tested them allseparately, I don't think I have a bad one.

Without the eLogger and Glow-Emulator the motor works, but the range is short, too short.

Would opto-isolating the Rx on it's own 200mAh 5V pack solve this?
Your thoughts andexperiencesplease.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.