Notices
Car Nitro & Gas Engines Discuss all aspects of Nitro and Gas rc car engines here!

firestorm broke first start

Old 05-07-2010, 08:40 PM
  #1  
1sickhatch
Junior Member
Thread Starter
 
Join Date: May 2010
Location: mountain top, PA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default firestorm broke first start

hey iam new to RC and i wanted to get into it so i went and bought a HPI Firestorm. i followed the directions and the first pull start to break it in the RPMs went really high and shut off. Now the pull start wont pull at all. Is the motor siezed up on it? or is somethen that i did wrong and will they warrentee it?
Old 05-07-2010, 08:56 PM
  #2  
Snook Man
Senior Member
 
Snook Man's Avatar
 
Join Date: Aug 2009
Location: , FL
Posts: 858
Likes: 0
Received 0 Likes on 0 Posts
Default RE: firestorm broke first start

Can you turn the flywheel by hand or with leverage?
Old 05-07-2010, 09:13 PM
  #3  
1sickhatch
Junior Member
Thread Starter
 
Join Date: May 2010
Location: mountain top, PA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default RE: firestorm broke first start

i cant turn it at all....
Old 05-07-2010, 09:23 PM
  #4  
Snook Man
Senior Member
 
Snook Man's Avatar
 
Join Date: Aug 2009
Location: , FL
Posts: 858
Likes: 0
Received 0 Likes on 0 Posts
Default RE: firestorm broke first start

Not a good sign. High rpms on a fresh engine first start can be fatal.
Crack it open to see what the problem is. Call the manufacturer for customer service.

Old 05-07-2010, 10:27 PM
  #5  
Shabbernigdo
 
Join Date: Dec 2009
Location: city
Posts: 766
Likes: 0
Received 1 Like on 1 Post
Default RE: firestorm broke first start

with it being that newthere more then likelygonna warentee it.

ide pull the cooling head off and look at the piston and sleve. with it being a new engine and all mabey the pistion is just pinched at TDC. IF it looks to be in good condition try heating it with a hair dryer and trying to turn the fly wheel.
Old 05-07-2010, 10:43 PM
  #6  
1sickhatch
Junior Member
Thread Starter
 
Join Date: May 2010
Location: mountain top, PA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default RE: firestorm broke first start

alright but if you pull it apart i dont know if it voids the warrentee if there is any...like i took it out of the box set it up and it blew on first pull they prob wont believe me but if not ill just buy another motor...
Old 05-07-2010, 11:18 PM
  #7  
secretsg
Senior Member
 
secretsg's Avatar
 
Join Date: Dec 2005
Location: Siberia, CANADA
Posts: 3,696
Likes: 0
Received 0 Likes on 0 Posts
Default RE: firestorm broke first start

There have been problems with the G3.0 engines in the past 6 months or so. I would open it up and give HPI a call. THey should be WELL AWARE of the issues by now.
Old 05-08-2010, 08:11 AM
  #8  
yakfish
My Feedback: (27)
 
yakfish's Avatar
 
Join Date: Feb 2008
Location: Fairborn, OH
Posts: 2,439
Likes: 0
Received 2 Likes on 2 Posts
Default RE: firestorm broke first start

I had one a couple years ago and it did the same thing just after breakin. Over revved and just stoped. I opened it up and founf the piston in a million pieces. HPI has a engine replacement plan where you send them your blown engine and $60 and they will send you a new one. I would do this if they won't replace it under warranty. then sell the brand new engine and get an OS 18CVR
Old 05-08-2010, 11:08 AM
  #9  
rpg711
Senior Member
 
Join Date: Jun 2007
Location: Hopkinton, MA
Posts: 213
Likes: 0
Received 0 Likes on 0 Posts
Default RE: firestorm broke first start

It wouldn't over rev if your idle screw was set correctly and your throttle servo was not wide open, I doubt they would warranty it for user error, unless the carb slide got stuck and it was a design problem, there is no possible way an engine revs with a .8mm venturi gap.
Old 05-08-2010, 11:23 AM
  #10  
1sickhatch
Junior Member
Thread Starter
 
Join Date: May 2010
Location: mountain top, PA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default RE: firestorm broke first start

I didnt touch the idel or the servo at all cause i was just trying to break it in the first tank the directions said to let it run...but on the first pull with not touching anything it over reved...i know iam new to these cars but sill shouldnt of blow that quick with touching that stuff on first pull

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.