Go Back  RCU Forums > RC Helicopters > Century - Predator, Hawk IV, Falcon, Raven
Reload this Page >

Predator Gasser 231 carb question

Notices

Predator Gasser 231 carb question

Old 09-21-2006, 08:50 AM
  #1  
koolhand
Thread Starter
My Feedback: (1)
 
Join Date: Apr 2002
Location: Kings Mountain, NC,
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default Predator Gasser 231 carb question

Hello all, I recently aquired a used Predator Gasser. I put my first flight on the helicopter this past weekend. All went well on the first flight (20mins), however on the second flight after 5 minutes of flight the motor completely quite. The end of the plug had a very black char on the end. I have no problem replacing the spark plug but this lead to a search on the web about this motor. This motor has the wt677 carborator on it. According to other vendors and a few other sites it is stated as almost a must to replace this carb with a wt643.
I need someone with more experience than me on gasser helicopter to tell me if indeed I need to replace the carb for performace and reliabilty reasons.

Thanks for the help

Koolhand
Old 09-21-2006, 10:30 AM
  #2  
DebianDog
Senior Member
 
DebianDog's Avatar
 
Join Date: Dec 2004
Location: Chester, VA
Posts: 1,376
Likes: 0
Received 1 Like on 1 Post
Default RE: Predator Gasser 231 carb question

As the gasser continues to break in you will need to lean it out a bit. Also what oil ratio are you running? You are running Lawn-Boy your first gallon right? It is hard to diagnose these things as sound is the best judge of how it is running but I have not heard of "having to" replace a particular carburetor.
Old 09-21-2006, 10:46 AM
  #3  
koolhand
Thread Starter
My Feedback: (1)
 
Join Date: Apr 2002
Location: Kings Mountain, NC,
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Predator Gasser 231 carb question

This chopper is used with plenty of run time on it. I am running 32:1 mix with Zenoah synthetic oil. I will make some mixture adjustments but was quite concerned with what I read on the net about how the wt677 was junk and that zenoah switched back to wt643 mid-stream of production. This is the link that I am refering to http://helifreak.com/viewtopic.php?t=305. I will replace the plug and start working more specifically with mixture settings.

Thanks for any input

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.