Go Back  RCU Forums > RC Helicopters > Electric RC Helis > E-Flite Helicopters
Reload this Page >

Blade SR no lift power after crash. Need help!

Notices
E-Flite Helicopters Discuss the line of E-Flite mini and micro helis including the Blade CP, CP Pro, Blade CX, etc

Blade SR no lift power after crash. Need help!

Old 03-13-2010, 10:36 PM
  #1  
Killjoy911
Junior Member
Thread Starter
 
Join Date: Mar 2010
Location: Vancouver, BC, CANADA
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default Blade SR no lift power after crash. Need help!

I am new to collective pitch heli and have a problem. I have the new Blade SR.After a hard crash, I noticed I no longer have lift. I can move the throttle to the max and I can hear the prop spin up to what sounds like full rotational speed but no lift. The tips of the blades have the white coating peeled back a bit but they look in good overall shape.
When doing a check on the cyclical control for the forward, back, left and right, the main blades move in the proper direction and the servos respond they way they should.
When I doa throttle test, I can see it speed up but when I look carefully at the swashplate, I dont notice any change to the blade pitch so I am thinking the problem with the lift is the blades are not moving to a higher pitch when I throttle up which I assume it should when I throttle up.
All linkages are straight and no visible damage anywhere. Why do I seem to have full control of all controls except for lift?
Old 03-13-2010, 10:54 PM
  #2  
badmechaaron
Junior Member
 
Join Date: Feb 2010
Location: , IL
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

Swashplate came apart!!!!
Old 03-13-2010, 10:58 PM
  #3  
badmechaaron
Junior Member
 
Join Date: Feb 2010
Location: , IL
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

Push down on the top of the swash and up on the bearing under it.  It should go back together or replace it.  Very common problem.
Old 03-13-2010, 11:57 PM
  #4  
Killjoy911
Junior Member
Thread Starter
 
Join Date: Mar 2010
Location: Vancouver, BC, CANADA
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

Not sure I see the problem. To me, the swashplate looks intact and together. The main swashplate is attached to the upper part of the assembly.
Old 03-14-2010, 03:10 AM
  #5  
9sec240
Senior Member
 
9sec240's Avatar
 
Join Date: Jan 2009
Location: Carol Stream, IL
Posts: 2,882
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

Check the bottom of the swash to see if the center is still sticking through the bearing. There should be a little plastic showing.

Attached Thumbnails Click image for larger version

Name:	Fc90061.jpg
Views:	102
Size:	105.2 KB
ID:	1397665  
Old 03-14-2010, 09:33 AM
  #6  
vupilot
 
Join Date: Sep 2004
Location: , IN
Posts: 164
Likes: 0
Received 1 Like on 1 Post
Default RE: Blade SR no lift power after crash. Need help!

Is the servo moving properly?
Old 03-14-2010, 12:57 PM
  #7  
46u
Senior Member
My Feedback: (3)
 
46u's Avatar
 
Join Date: Jan 2005
Location: Macon, GA
Posts: 22,095
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

I had the same problem twice after a crash once it was the swash plate which I think caused the crash and the second time it was because the feathering shaft was bent. The feathering shaft is the shaft that goes between the bell mixer main blade grips.
Old 03-14-2010, 06:23 PM
  #8  
Killjoy911
Junior Member
Thread Starter
 
Join Date: Mar 2010
Location: Vancouver, BC, CANADA
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

Thanks for all the helpfull suggestions guys. Everything Ican see on the swashplate looks good. The baring is in the proper place and no deformation to the plate. The main shaft is good and spins correctly. Unfortunetly I think it might be the feathering shaft as well. Its only thing left I can think of. Iwill trya new set of blades out first once the weather gets better(been raining for days), if that does not work, I might have to get the feathering bar.
Old 03-14-2010, 08:39 PM
  #9  
46u
Senior Member
My Feedback: (3)
 
46u's Avatar
 
Join Date: Jan 2005
Location: Macon, GA
Posts: 22,095
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

If your blade tracking is way off or one blade has more pitch then the other more then likely it is the feathering shaft. When it happen to me it took me a while to figure it out till I noticed a BIG difference in pitch between the two blades.
Old 03-15-2010, 06:31 PM
  #10  
badmechaaron
Junior Member
 
Join Date: Feb 2010
Location: , IL
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

To check the feathering shaft just take one blade off and turn the screw inside the grip and you will see the two grips wobble if its bent.
Old 03-15-2010, 06:49 PM
  #11  
Ddaddy
Senior Member
 
Join Date: Dec 2009
Location: Red Oak, TX
Posts: 513
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!


ORIGINAL: badmechaaron

To check the feathering shaft just take one blade off and turn the screw inside the grip and you will see the two grips wobble if its bent.
Ditto above...and you should be seeing quite a bit of vibration when she spools up.

Disconnect2 plugs going to motor and power up. Do you see the swash move down when you move left stick up? Positive (lift) pitch on blades?

triple check swash

Ken

Old 03-16-2010, 08:51 AM
  #12  
Killjoy911
Junior Member
Thread Starter
 
Join Date: Mar 2010
Location: Vancouver, BC, CANADA
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Blade SR no lift power after crash. Need help!

Not my first guess but in the end, it was the main blades. Put on a new set and it worked. I think there must of been damage under the white wraper that was just enough to throw off the lift that I could not see. Oh well, live and learn. Thanks for all the help, this forum site has been really great for info.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.