Go Back  RCU Forums > Electric Aircraft Universe > Electric General Discussion
Reload this Page >

St Model Fox EP Problem w/Power System after Crash _Plz Help !

Notices
Electric General Discussion General Discussion forum about rc electric related aircraft, accessories, flight, tips, etc.

St Model Fox EP Problem w/Power System after Crash _Plz Help !

Old 03-26-2012, 07:16 AM
  #1  
VictoryRoll
Thread Starter
My Feedback: (2)
 
VictoryRoll's Avatar
 
Join Date: May 2008
Location: Norfolk, MA
Posts: 289
Likes: 0
Received 0 Likes on 0 Posts
Default St Model Fox EP Problem w/Power System after Crash _Plz Help !

Hi All,

I have an St Model Fox EP, which can be found here:www3.towerhobbies.com/cgi-bin/wti0001p

I took her out on a very windy day and proceeded to have a short but memorable flight... nosed-dived straight into ground... Frankly, I believe mysetup(esp. elevevator or CG) was way off.

Although the crash did not do a whole lot of damage toofuse, etc., the motor mount was cracked in which I proceeded to make a new one (I have all dimensions if someone would like/need).

Put motor back in, and tried to run without success. Basically the motor, when applying throttle, just wiggles back and forth a bit and stops. Bring throttle to off, then reapply throttle, does the same quivering of the prop w/ no real revolutions on the prop/motor.

I tried to check if theESCbrake was on, but to do that, I need to "hear" one or two beeps after power/battery connected, which I do not... nothing.. no beeps whatsoever. Just the twitching of the prop. Without the beeps, I cannot tell if brake is on, so I followed procedure for turning the ESC brake OFF and ON, and off and on.. etc. Same result.

What do you suppose is the problem? The ESC gone? The motor broken? I have no idea, as this is my first electric powered aircraft.

Any help and/or suggestions would be greatly appreciated, as I do not want to replace parts just at random w/o knowing what specifically should be replaced and why.

I thank you in advance for your time and help.

Don
Old 03-26-2012, 07:58 AM
  #2  
jzrf6c
Senior Member
 
Join Date: Jun 2005
Location: Prescott Valley, AZ
Posts: 565
Likes: 0
Received 0 Likes on 0 Posts
Default RE: St Model Fox EP Problem w/Power System after Crash _Plz Help !

check for a broken/loose wire from the motor to the ESC. I've found that I get this indication when one of the connection is bad.
Old 03-26-2012, 08:03 AM
  #3  
VictoryRoll
Thread Starter
My Feedback: (2)
 
VictoryRoll's Avatar
 
Join Date: May 2008
Location: Norfolk, MA
Posts: 289
Likes: 0
Received 0 Likes on 0 Posts
Default RE: St Model Fox EP Problem w/Power System after Crash _Plz Help !

Thanks jz... I appreciate it.. I will try it out today
Thanks again,
Don

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.