Notices
Electric Indoor & Micro RC Flight Talk about this fast growing niche in rc. Micro radios, micro electric or co2 powered planes, heli's both indoors and out.

MPI MX-50HP Problems

Old 04-23-2005, 08:27 AM
  #1  
indyrcpilot
Member
Thread Starter
 
Join Date: Jan 2002
Location: Indianapolis, IN
Posts: 32
Likes: 0
Received 0 Likes on 0 Posts
Default MPI MX-50HP Problems

Has anyone else had any problems with the MPI MX-50HP servos? These are the orange naro-sized servos that put out 23 oz/in of torque. I've been using them in many of my electric planes, due to the higher torque for their size/weight.

Just recently, I've had (4) of them fail. Two on a Slow Stick (on rudder both times), and two on a full size IFO (one on each side). In each case, the servo just seemed to lock up and suck the life out of the BEC on the ESC, i.e., no longer had control. Fortunately, none of the incidents occurred at altitude, so the planes survived.

All but one of these failures was on servos that had seen quite a bit of usage. Anyone out there have any idea what might be causing these failures???

Thanks!
Chuck

Old 05-09-2005, 11:00 PM
  #2  
voodoo_chicken1
Senior Member
 
Join Date: Sep 2003
Location: Brookfield, IL
Posts: 102
Likes: 0
Received 0 Likes on 0 Posts
Default RE: MPI MX-50HP Problems

How many servos were you running and what was your set-up? If you were using 4 servos, your speed controller probably couldn't handle the current draw. CC esc handle 1.5 amps for the servos. I bet your esc got super hot. Thats because it was working too hard to reduce the voltage from your battery to run the servos and receiver. If your using 4 servos or servos that pull a high current, you'll need a seperate BEC. Do a search of SBEC, UBEC and begin your research.

http://rcelectrichobbies.com/Other/B...-BEC-35020.htm
http://www.aircraft-world.com/prod_d...sbec/s-bec.htm
http://www.koolflightsystems.com/ultimatebec.htm

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.