Go Back  RCU Forums > Electric Aircraft Universe > Electric Pattern Aircraft
Reload this Page >

CC Phoenix Ice2 HV80 problems

Notices
Electric Pattern Aircraft Discuss epowered pattern aircraft in this forum

CC Phoenix Ice2 HV80 problems

Old 05-19-2013, 09:39 AM
  #1  
rodney tanner
Senior Member
Thread Starter
 
rodney tanner's Avatar
 
Join Date: Jan 2004
Location: La Herradura Edo. de Mexico, 53920 MEXICO
Posts: 390
Likes: 0
Received 0 Likes on 0 Posts
Default CC Phoenix Ice2 HV80 problems

I have recently purchased a Phoenix ICE 80 HV vers 2 from F3A Unlimited
for use with an E-flight Power 90 on an 8s setup.

I set up 80 HV as per instructions with no programming (Futaba Tx)
Everything worked fine.
I then connected the C-link and set throttle end points and a 24v cut off.
(When disconnecting the motor the white lead came off the connector.
I resoldered the connector).
When I try to power up and arm the esc. I got a 4 beep error.
Followed by a continuous beep.
I reconnected the C-link and set to default factory settings.
Still getting the 4 beep error followed by a continuous beep.
So the only variable I can see here is the motor connector I resoldered.
Perhaps I didn't do a very good job on the soldering and the cable did not seat completely
into the connector?
Could this be the problem resulting in a 4 beep error?
BTW What does the continuous beep mean? Nothing in the manual.

I have contacted CC but any thoughts or tips would be most appreciated.
Old 05-19-2013, 06:58 PM
  #2  
Jetdesign
My Feedback: (8)
 
Jetdesign's Avatar
 
Join Date: May 2008
Location: Honolulu, HI
Posts: 7,056
Received 0 Likes on 0 Posts
Default RE: CC Phoenix Ice2 HV80 problems

First thing you should do is see what version firmware you are running, and go to Castle's website and see if there are any bugs with that version:
http://castlecreations.com/downloads/frh-phoenix.html

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.