Go Back  RCU Forums > RC Helicopters > Electric RC Helis
Reload this Page >

Why is this happening to my LIPO!?!??

Notices
Electric RC Helis Discuss electric rc heli's such as the Piccolo, Logo 10, Logo 20, Hornet, Eco.

Why is this happening to my LIPO!?!??

Old 03-26-2008, 08:07 PM
  #1  
chevypower1930
Thread Starter
 
Join Date: Jun 2006
Location: Raleigh, NC
Posts: 1,006
Likes: 0
Received 0 Likes on 0 Posts
Default Why is this happening to my LIPO!?!??

Alright yall I have an Axe CP-l with a lipo...
all has been going well and haven't done anything bad w/ the battery but just yesterday when i tried to charge the lipo it would just KEEP charging... the light would not turn green to mean full charge? I would plug it into the heli and try to fly and just almost NO power... not even enough to lift off... so anybody know whats happening to my lipo?
Old 03-26-2008, 08:16 PM
  #2  
W4RCF
Senior Member
 
Join Date: Jan 2002
Location: Goldsboro, NC
Posts: 155
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Why is this happening to my LIPO!?!??

Did you accidentally leave it plugged in after flying for several hours? Hope not!
Old 03-26-2008, 08:19 PM
  #3  
chevypower1930
Thread Starter
 
Join Date: Jun 2006
Location: Raleigh, NC
Posts: 1,006
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Why is this happening to my LIPO!?!??

Nope.. I didn't... i never do, I fly and take it directly out
Old 03-26-2008, 08:20 PM
  #4  
dknovick
Senior Member
 
dknovick's Avatar
 
Join Date: Jan 2005
Location: Albuquerque, NM
Posts: 2,043
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Why is this happening to my LIPO!?!??


ORIGINAL: chevypower1930

Alright yall I have an Axe CP-l with a lipo...
all has been going well and haven't done anything bad w/ the battery but just yesterday when i tried to charge the lipo it would just KEEP charging... the light would not turn green to mean full charge? I would plug it into the heli and try to fly and just almost NO power... not even enough to lift off... so anybody know whats happening to my lipo?
Is it a 2S or 3S. What's the voltage across the battery?
Old 03-26-2008, 08:21 PM
  #5  
chevypower1930
Thread Starter
 
Join Date: Jun 2006
Location: Raleigh, NC
Posts: 1,006
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Why is this happening to my LIPO!?!??

its 3s.. i have no idea is there anything just lipo generally that could be wrong
Old 03-26-2008, 09:57 PM
  #6  
Druss
Senior Member
 
Join Date: Aug 2007
Location: Edmonton, AB, CANADA
Posts: 7,441
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Why is this happening to my LIPO!?!??

if you over discharged it, as in ran it in the heli till you couldn't fly anymore, then you probably killed it. you cannot discharge a lipo under 3v per cell. get a volt meter and check the voltage, if it's under 9v or any individual cell is under 3v then you've got a dead lipo.
Old 03-26-2008, 10:33 PM
  #7  
srouthouse
Senior Member
 
Join Date: Nov 2007
Location: auburn, CA
Posts: 735
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Why is this happening to my LIPO!?!??

the lipo is low and can be recharged with a good charger, may not have all its life but running it low once shouldt kill it.

im betting on the cheap charger your using is not rite. [had one like yours once do the same thing]
Old 03-27-2008, 04:19 AM
  #8  
jez33
Senior Member
 
Join Date: Jan 2006
Location: hastingskent, UNITED KINGDOM
Posts: 337
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Why is this happening to my LIPO!?!??


ORIGINAL: chevypower1930

Alright yall I have an Axe CP-l with a lipo...
all has been going well and haven't done anything bad w/ the battery but just yesterday when i tried to charge the lipo it would just KEEP charging... the light would not turn green to mean full charge? I would plug it into the heli and try to fly and just almost NO power... not even enough to lift off... so anybody know whats happening to my lipo?
hi.
be careful leaving your lipo on charge if you think it has a problem.
i had a lipo which for the 1st aprox 10 flights worked and charged well but one day i put it on charge and the battery just kept charging and charging.. after a few hours longer then it should have taken to charge the lipo exploded and caught fire.. i luckily had taken a few precautions so no damage to my room where it was being charged..
in my case though i think i can blame the charger as i was using a charger for lipos i brought from ebay which was one of those cheaper chargers from china.…

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.