Go Back  RCU Forums > RC Helicopters > Flybarless Helicopters
Reload this Page >

Copter/X 450 Black Angel and CX-3x2000 with Spektrum DX8

Notices
Flybarless Helicopters Discuss flybarless rotor head systems for all helicopters right here.

Copter/X 450 Black Angel and CX-3x2000 with Spektrum DX8

Old 09-12-2014, 08:32 PM
  #1  
TATIG
Junior Member
Thread Starter
 
Join Date: Aug 2014
Posts: 27
Likes: 0
Received 0 Likes on 0 Posts
Unhappy Copter/X 450 Black Angel and CX-3x2000 with Spektrum DX8

[TABLE="class: tableBorder, width: 1314, align: center"]
[TR="class: PMtableRow, bgcolor: #FBFBFD"]
[TD]Hi

I am running 2 Copter/X 450 Black Angels FBL, CX-3x2000 and CX-3x1000 with a Spektrum DX8. I have tested the CX-3x1000 with a CX450BAs in the older Spektrum DX7 I used to have and it works smoothly. When I configure with the Spektrum DX8 software v2.4 of the GYRO, the test in the bench works out very nicely, but when I test it in the ground, I am having trouble controlling it, at 50% throttle, the tail starts spinning. I have adjusted the gain and my throttle curve (giving more power) but still the same.

As for the other C450BA with the CX-3x2000, I took the CX450BA completely apart and put it back together, including good balanced blades in both rotors. Ensure that everything was in working order... No vibrations.

When I tested it in the bench, I could see the servos working properly, no vibration and no sounds or binds.

Anyway, I took it out and as soon as I got to 50% it started shifting the swash to the left, by trying to correct it, I applied AILE and tilt it the heli to the other side rather quickly and hit the tips of the blades. It is rather touchy even though I have 40% EXPO on it.

I tried it with the DX7 and it is the same. So there must be something wrong in the heli, as it could not be the TXs and the CX-3x2000 looks ok. There is something peculiar in the DX8 with the Software for the CX-3x2000 though (and the same happens in the CX-3x1000). When in the Monitor Tab of the software, I set the correct direction for each stick, AILE, ELEV, RUDD and PITCH. I am able to center the sticks. But when I try to adjust the endpoints for the AILE and ELEV, I cannot increase the throw to 100% in the software, even though I have reached 150% in the DX8. This does not happen in for the RUDD, and PITCH, I am able to increase the throw in the DX8 to 105% and the software shows 100%.

I thought it would be an issue with the DX8, but these are the endpoints, Why is tipping one way or the other and the sticks are touchy??? It has to do something with the servos but I do not see anything wrong with them... I am using a 45A ESC, 2200 Lipo, HK-922MG digital servo's in the swash. And the FUSONIC (CX) servo in the rudder.

No idea what could be, and I already busted 5 pair of blades, 1 shaft, two gears, and 1 feathering shaft...

HELP would be much appreciated.

Thank you
[/TD]
[/TR]
[TR="class: tableBottomRow, bgcolor: #D3DAED"]
[TD][/TD]
[/TR]
[/TABLE]
Old 10-07-2014, 01:37 PM
  #2  
TATIG
Junior Member
Thread Starter
 
Join Date: Aug 2014
Posts: 27
Likes: 0
Received 0 Likes on 0 Posts
Default

Problem solved... Nothing to do with the DX8, nothing to do with the Orange RXc(as recommended by Horizon)... it was in fact that the manual describes the position of the CX-3x2000 on the left side up-side-up with cables running towards the boom... when looking closely to the software v2.4, it is hard to see, but the cables are towards the front... once changed, the heli was hovering without a hitch... Thank you...

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.