Notices
Foamies! - RC Electric Foam Aircraft Discuss rc foamie electrics here (i.e. Zagi, Tazz, ProJeti, wingo)

FMS P51 57 Inch Version 8

Old 05-23-2016, 07:35 PM
  #1  
Thread Starter
 
Join Date: Nov 2015
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
Default FMS P51 57 Inch Version 8

Guys, I have a 57 inch FMS P51 V8. I did the prop mod with pieces of tie wrap under the leading edge of the propellers and at 3/4 to full power she wants to roll right. Had to give it almost full left ailerons and power down to about 1/3 power to land it. Additionally, had wing tanks on and gear down the entire maiden flight. Fortunately I landed it without further incident. After landing I checked all control surfaces and they all appeared normal. Thinking about trying it again without the wing tanks. Did the prop mod produce additional/too much torque with additional power? Any suggestions? Thanks
Old 05-28-2016, 04:41 PM
  #2  
 
Join Date: Apr 2009
Location: Calgary, AB, CANADA
Posts: 32
Likes: 0
Received 0 Likes on 0 Posts
Default

You should fly it stock just to see if the same characteristic is present. I've done the zip tie mod and the plane does not exhibit this tendency. There may be something else going on with your plane, perhaps something in the set up. You won't know for sure until you fly it without the modded blade pitch. The zip tie mod does provide noticeable improvement in pull but it can be problematic. You can't use ties that are more than about 1mm thick and they must all be uniform in thickness and cinched down exactly the same. They tend to compress differently with different torque on the blade screws and there is also a tendency for that little ridge on the blade holder in front of each zip tie, to get squeezed out. This is not a good thing.
The better mod now is substituting the motor from the new FMS P-40. It spins a lot faster on the same cell count and gives the P-51 the much needed performance boost that it deserves. Another mod if you are a speed demon is to get the motor from the FMS Olympus and fly it on 6 cells. You'll need the X-mount and 2 blade prop from the Olympus as well. If you want to keep using the stock prop, you'll need to increase the ESC to about 120A+.
Old 05-29-2016, 12:40 PM
  #3  
Thread Starter
 
Join Date: Nov 2015
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
Default

Xviper-1, Thanks for the information but I found the source of the problem. I didn't properly secure the wing (didn't tighten the 4 wing screws) enough. This caused the wing to rock in the wind. Once tightened down it flew flawlessly.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.