Notices
Futaba Radios Direct support forum Ask any questions you may have about Futaba radios and product here and get answers direct from Futaba

8FG SD card

Old 11-27-2013, 03:01 PM
  #1  
aghost
Thread Starter
My Feedback: (13)
 
aghost's Avatar
 
Join Date: May 2002
Location: Amarillo, TX
Posts: 1,239
Received 2 Likes on 2 Posts
Default 8FG SD card

I have a 2G Standard SD card from SanDisk that I have been using since I bought the 8FG several years ago. No problems with the TX or card but I decided to buy a second card as a backup.

I bought another 2G Standard SD card from SanDisk, making sure I matched the first one. When I try to format the new card, my 8FG insists the card is write protected. The lock is in the "unlock" position and my desktop computer (W7) will read/write this card, no problem. For some reason the TX and this card are not compatible. I purchased this card new from Amazon and it came in a SanDisk mailer.

Is anyone else having difficulties with recently purchased 2G cards? I don't want to order more cards if they are not going to work. A 2G standard card is not much good for anything else nowadays. I don't feel I should send this one back since it obviously works.

Or any other suggestions- different manufacture whose cards are compatible??

Brian
Old 11-27-2013, 04:56 PM
  #2  
Robert Willis
 
Join Date: Nov 2013
Posts: 59
Likes: 0
Received 1 Like on 1 Post
Default

Try re-formatting the card with your desktop computer. After it is formatted try it in your 8FG to see if will now recognize it properly. I have had issues before with memory cards not being recognized until re-formatted.
Old 11-27-2013, 05:17 PM
  #3  
aghost
Thread Starter
My Feedback: (13)
 
aghost's Avatar
 
Join Date: May 2002
Location: Amarillo, TX
Posts: 1,239
Received 2 Likes on 2 Posts
Default

Robert: just tried your suggestion. didn't help. The desktop re-formatted the SD card and the desktop did read/write on it. 8FG still indicates it is "write protected" and will not format it.

thanks anyway,
Brian
Old 12-05-2013, 05:36 PM
  #4  
aghost
Thread Starter
My Feedback: (13)
 
aghost's Avatar
 
Join Date: May 2002
Location: Amarillo, TX
Posts: 1,239
Received 2 Likes on 2 Posts
Default

OP's continued testing. Another 8FG read/write the problem card just fine. So I guess its my TX. I will clean out the card slot and see if that helps. If not, its off the the repair facility.

Brian

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.