Notices
Futaba Radios Direct support forum Ask any questions you may have about Futaba radios and product here and get answers direct from Futaba

T7C buddy box leads

Old 08-05-2018, 01:43 AM
  #1  
davidej
Thread Starter
 
Join Date: Nov 2002
Location: West Mersea, UNITED KINGDOM
Posts: 139
Likes: 0
Received 0 Likes on 0 Posts
Default T7C buddy box leads

I have two T7Cs and a lead and was trying to teach my grandchildren to fly.

If the plugs are pressed hard into the Tx sockets, then contact between the two is established. But the slightest bit of movement of the lead , such as picking up the Tx disturbs the contacts and control is lost.

At first I thought it was a faulty lead but I have got a second one and the result is the same. I also have a third T7C (35meg) which I have tried with no success.

Am I doing something wrong or is this a design failure?
Old 08-05-2018, 07:27 AM
  #2  
FUTABA-RC
 
FUTABA-RC's Avatar
 
Join Date: Oct 2017
Posts: 1,190
Received 22 Likes on 22 Posts
Default

It sounds to me like perhaps you do not have the correct cable. I would contact Ripmax to confirm the cable and to see if there is another available.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.