Notices
Gas Engines Questions or comments about gas engines can be posted here

Rovan Q Baja won't start

Old 12-18-2019, 07:21 PM
  #1  
Caleb M
Junior Member
Thread Starter
 
Join Date: Dec 2019
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Question Rovan Q Baja won't start

My Rovan Q baja won't start, first thought it was flooded but it wasn't. Checked all the fuel lines but they are fine, when I took the carb off, it looks like there is no fuel getting to the engine. Fuel still moves through the return lines when I prime the carb but no fuel goes into the intake of the engine. What is going on here and what can I do to fix this? Any ideas?
Old 12-19-2019, 05:54 AM
  #2  
erik58
My Feedback: (4)
 
Join Date: Jan 2003
Location: easthaven, CT
Posts: 212
Likes: 0
Received 0 Likes on 0 Posts
Talking

Check the height of the metering lever some times itís off if it does not open no fuel will go into the carb
Old 12-19-2019, 08:17 PM
  #3  
Caleb M
Junior Member
Thread Starter
 
Join Date: Dec 2019
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

I tried that, I can't get fuel into the engine even on full throttle. I don't know if one of the internal passages of the carb is blocked or if there is just an air leak in it. Is there any way to trouble shoot the carb?
Old 12-20-2019, 04:25 AM
  #4  
erik58
My Feedback: (4)
 
Join Date: Jan 2003
Location: easthaven, CT
Posts: 212
Likes: 0
Received 0 Likes on 0 Posts
Default

Is the diaphragm ok? The needle sticking?it sound like itís plugged.I would also see if there is a vacuum leak or the gasket is on right and the pulse hole is open
Old 12-20-2019, 01:23 PM
  #5  
Caleb M
Junior Member
Thread Starter
 
Join Date: Dec 2019
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

How do I check to see if there is a vacuum leak? I think the needles are fine, they don't feel stuck. As for the diaphragm, I've never really seen the inside of a carb before now but it doesn't look damaged or otherwise blocked. I will check the gaskets. When it stopped working, it was running perfectly at idle then it started to slow down, but I wasn't too worried, when it slowed even more i gave it gas to keep it going but it kind of sputtered but stayed running, it never moved or sped up though. I returned it to idle and went to change the low speed needle to make it idle faster but it died before I did anything. Still wasn't worried so I pulled the cord to start it again because it was still hot, it didn't start after a few pulls so I put the choke on and pulled it. It popped once so I took the choke off and pulled it a few times but it didn't start so I primed it and choked it repeatedly but I could never get it to start or even pop again. I thought it was flooded so I took the spark plug out but nothing came out of the engine and there was nothing in it. I took apart the carb and air filter assembly but couldn't figure it out so here I am now.

Last edited by Caleb M; 12-20-2019 at 01:31 PM.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.