Notices
Glow Engines Discuss RC glow engines

Welcome to Club SAITO !

Old 12-16-2023, 05:05 AM
  #54476  
Glowgeek
 
Join Date: Feb 2016
Posts: 3,590
Received 64 Likes on 64 Posts
Default

Originally Posted by modeltronics
I just looked over the engine and there are no markings on the lugs. Does that give an idea of the age of the engine?
Watch your fingers!
Old 12-16-2023, 05:44 AM
  #54477  
modeltronics
My Feedback: (27)
 
Join Date: Feb 2002
Location: Cross Plains, TX
Posts: 578
Received 6 Likes on 5 Posts
Default

Lonnie, are you hinting that this is a high compression engine?
Old 12-16-2023, 05:56 AM
  #54478  
Glowgeek
 
Join Date: Feb 2016
Posts: 3,590
Received 64 Likes on 64 Posts
Default

Originally Posted by modeltronics
Lonnie, are you hinting that this is a high compression engine?
Depends on if the case is original to the engine or not. The first release of the 150, having no letter stamped on the lug, were high compression engines. Replacement cases however also have no markings.

With the internals of your engine showing little signs of wear I'd say there is a very high likelihood that it's an early high compression version.

IIRC, there are no visual features, internal or external, to conclusively say it's high compression, you will have to measure the piston and rod to determine it. Either that or "CC" the combustion chamber using fluid.

Last edited by Glowgeek; 12-16-2023 at 06:02 AM.
Old 12-16-2023, 06:11 AM
  #54479  
modeltronics
My Feedback: (27)
 
Join Date: Feb 2002
Location: Cross Plains, TX
Posts: 578
Received 6 Likes on 5 Posts
Default

If it is a high compression version of the 150 then it should be fine on my home brew fuel that is only 3% nitro. I have no idea of the history of this engine but I would guess that it is all original parts. I do know it was stuck bad. Amazing what a little heat will do to fix that.
Old 12-16-2023, 08:17 AM
  #54480  
Jesse Open
 
Jesse Open's Avatar
 
Join Date: Mar 2018
Location: 30 Miles North of Canada Border
Posts: 3,774
Received 91 Likes on 83 Posts
Default

Good catch there. Even the HC versions are *****cats to start using the backflip method.

Make that kittycats, the Puritan filter rejects the P word

Old 12-16-2023, 09:18 AM
  #54481  
Glowgeek
 
Join Date: Feb 2016
Posts: 3,590
Received 64 Likes on 64 Posts
Default

Originally Posted by Jesse Open
Good catch there. Even the HC versions are *****cats to start using the backflip method.

Make that kittycats, the Puritan filter rejects the P word
I never got proficient using that technique. Nowadays there's always a starter between my phalanges and the prop where glow ignition is used. Even with some gassers like the FG-21. All three of mine can be stubborn to cold start. Once warmed up they fire off with a flip or two. Always thought they should have included a choke mechanism.
Old 12-16-2023, 09:52 AM
  #54482  
Hyjinx
 
Join Date: Dec 2015
Posts: 953
Received 31 Likes on 31 Posts
Default

Sort of off topic but..
One. Anyone having this site crash your android system when responding to notifications from e mail?
Two. Has been impossible to upload images and or video. Anyone else dealing with these frustrations?
Old 12-16-2023, 10:43 AM
  #54483  
Jesse Open
 
Jesse Open's Avatar
 
Join Date: Mar 2018
Location: 30 Miles North of Canada Border
Posts: 3,774
Received 91 Likes on 83 Posts
Default

Originally Posted by Glowgeek
I never got proficient using that technique. Nowadays there's always a starter between my phalanges and the prop where glow ignition is used. Even with some gassers like the FG-21. All three of mine can be stubborn to cold start. Once warmed up they fire off with a flip or two. Always thought they should have included a choke mechanism.
While I at times use starters on the smaller Saitos; Generally nothing more than a leather glove on all the big ones. All the glow engines are very easy to start.

You can almost shave with some of those composite props!


Aaron,

Not using a 'Droid but see different hiccups with iPhone...

Last edited by Jesse Open; 12-16-2023 at 10:46 AM.
Old 12-16-2023, 11:03 AM
  #54484  
Glowgeek
 
Join Date: Feb 2016
Posts: 3,590
Received 64 Likes on 64 Posts
Default Upload Test

Seems to be working on my Android 11 tablet.

2014


Last edited by Glowgeek; 12-16-2023 at 11:08 AM.
Old 12-16-2023, 12:48 PM
  #54485  
acdii
 
Join Date: Jan 2011
Location: Capron, IL
Posts: 10,000
Received 97 Likes on 88 Posts
Default

Originally Posted by Hyjinx
Sort of off topic but..
One. Anyone having this site crash your android system when responding to notifications from e mail?
Two. Has been impossible to upload images and or video. Anyone else dealing with these frustrations?
I want to upload a picture of a plane I just acquired, but no links for attachments anywhere.

Hey Guys! Long time no posts. For some reason I stopped getting emails from this site, so haven't replied to anything. I also haven't been getting emails from HBO Max unless I send a support email in, then get a reply email, but none after that and no, not in my spam folder, I just don't get them.
Old 12-16-2023, 07:43 PM
  #54486  
FlyerInOKC
My Feedback: (6)
 
FlyerInOKC's Avatar
 
Join Date: Nov 2004
Location: Oklahoma City, OK
Posts: 14,148
Received 271 Likes on 236 Posts
Default

I haven't got notices from RCU in years, I just quit caring.
Old 12-16-2023, 08:48 PM
  #54487  
Jesse Open
 
Jesse Open's Avatar
 
Join Date: Mar 2018
Location: 30 Miles North of Canada Border
Posts: 3,774
Received 91 Likes on 83 Posts
Default

Originally Posted by FlyerInOKC
I haven't got notices from RCU in years, I just quit caring.
Sounds like they did too!



Nice pic Lonnie
Three happy kids.
Old 12-16-2023, 11:21 PM
  #54488  
Hyjinx
 
Join Date: Dec 2015
Posts: 953
Received 31 Likes on 31 Posts
Default

Originally Posted by Glowgeek
Seems to be working on my Android 11 tablet.

2014
2014- hope their driving you around in 2023 lol..
Don't know Lonnie. Can't well explain, stuff is either different and doesn't work or it's different and doesn't work....
Granted, the memory of the phone is clogged up with miles of video lol
Old 12-17-2023, 03:29 AM
  #54489  
1200SportsterRider
Senior Member
 
1200SportsterRider's Avatar
 
Join Date: Dec 2019
Location: Virginia
Posts: 1,125
Likes: 0
Received 34 Likes on 34 Posts
Default

I get, GO ADVANCED but no MANAGE ATTACHMENTS option. I may call Barracuda Hockey and ask him, what gives.

Last edited by 1200SportsterRider; 12-17-2023 at 04:24 AM.
Old 12-17-2023, 04:16 AM
  #54490  
BarracudaHockey
My Feedback: (11)
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 26,991
Received 351 Likes on 281 Posts
Default

i have a manage attachment button when i click GO ADVANCED


Old 12-17-2023, 04:27 AM
  #54491  
1200SportsterRider
Senior Member
 
1200SportsterRider's Avatar
 
Join Date: Dec 2019
Location: Virginia
Posts: 1,125
Likes: 0
Received 34 Likes on 34 Posts
Default

Thanks Andy, several of us here do not get the Manage Attachments option on Edit nor on Reply. I'm in district 4 a ways north of you. If ever come to one of our Heli Mowdowns make sure I know you're coming. Thanks https://fredericksburgrc.com/farcc-events/

Last edited by 1200SportsterRider; 12-17-2023 at 04:31 AM.
Old 12-17-2023, 06:44 AM
  #54492  
BarracudaHockey
My Feedback: (11)
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 26,991
Received 351 Likes on 281 Posts
Default

Sounds great!

I wonder if its a browser specific issue, I'm using Chrome
Old 12-17-2023, 10:07 AM
  #54493  
acdii
 
Join Date: Jan 2011
Location: Capron, IL
Posts: 10,000
Received 97 Likes on 88 Posts
Default

I have a thread under giant scale, yesterday, no attachments nor anything above with the font, hyperlink, attachments, none of that stuff. Today though it was there so I could upload the plane pic. Here though, nothing, all blank, not even an empty space where they would be at.

I take it back, it WAS there, but now its just like this one. Weird.

Last edited by acdii; 12-17-2023 at 10:09 AM.
Old 12-17-2023, 02:27 PM
  #54494  
Hyjinx
 
Join Date: Dec 2015
Posts: 953
Received 31 Likes on 31 Posts
Default

Originally Posted by acdii
I have a thread under giant scale, yesterday, no attachments nor anything above with the font, hyperlink, attachments, none of that stuff. Today though it was there so I could upload the plane pic. Here though, nothing, all blank, not even an empty space where they would be at.

I take it back, it WAS there, but now its just like this one. Weird.
Yep weird. I just hit quote tab and the dialog box came up. The manage attachments link below is dead so you can't open any files to send (or manage).
I'm going to try again now by using the reply to thread u blue box at the bottom rather than "quote"
Old 12-17-2023, 02:59 PM
  #54495  
FlyerInOKC
My Feedback: (6)
 
FlyerInOKC's Avatar
 
Join Date: Nov 2004
Location: Oklahoma City, OK
Posts: 14,148
Received 271 Likes on 236 Posts
Default

Must be the cheap Chinese software they bought or North Korean hackers.
Old 12-17-2023, 04:49 PM
  #54496  
Jesse Open
 
Jesse Open's Avatar
 
Join Date: Mar 2018
Location: 30 Miles North of Canada Border
Posts: 3,774
Received 91 Likes on 83 Posts
Default

Let's see if I can post a link. Have had problems with that at times This is a real extensive site on vintage American R/C gear;

https://www.vintagercfiles.com/Early_RC.html
Old 12-17-2023, 05:01 PM
  #54497  
modeltronics
My Feedback: (27)
 
Join Date: Feb 2002
Location: Cross Plains, TX
Posts: 578
Received 6 Likes on 5 Posts
Default

Gary, it worked for me. I need to bookmark that one. Very interesting.
Old 12-18-2023, 02:39 AM
  #54498  
1200SportsterRider
Senior Member
 
1200SportsterRider's Avatar
 
Join Date: Dec 2019
Location: Virginia
Posts: 1,125
Likes: 0
Received 34 Likes on 34 Posts
Default

Originally Posted by BarracudaHockey
Sounds great!

I wonder if its a browser specific issue, I'm using Chrome
Thanks Andy, I use Chrome also.
Old 12-18-2023, 01:34 PM
  #54499  
Jesse Open
 
Jesse Open's Avatar
 
Join Date: Mar 2018
Location: 30 Miles North of Canada Border
Posts: 3,774
Received 91 Likes on 83 Posts
Default

Originally Posted by modeltronics
Gary, it worked for me. I need to bookmark that one. Very interesting.
Very expansive and loads of info on vintage radio gear.
Click on the magazines and pull up some awesome articles .
Old 12-18-2023, 08:03 PM
  #54500  
the Wasp
My Feedback: (1)
 
Join Date: Sep 2003
Location: VT
Posts: 5,384
Likes: 0
Received 41 Likes on 39 Posts
Default

lets see if it works for me,,,

Early_RC (vintagercfiles.com)

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.