Notices
Glow Engines Discuss RC glow engines

Saito 100 No muffler preasure

Old 02-04-2008, 04:39 PM
  #1  
thunderbolts
Member
Thread Starter
 
Join Date: Nov 2005
Location: Northwich, UNITED KINGDOM
Posts: 49
Likes: 0
Received 0 Likes on 0 Posts
Default Saito 100 No muffler preasure

I have a saito FA-100 that I have had to rebuild with new pushrods due to crash damage. I have checked the compression and the timing is spot on. Everything seems fine so try to prime the motor before I start it. For some reason the motor will not prime and I am not getting enough muffler presure to feed the fuel from the tank.

Checked the tank and connections and pipes just cant get the motor to provide the fuel through muffler presure. Primed the motor manually with a little fuel and the motor fires and runs for a second no problem then cuts through no fuel. I cannot see ant air leaks anywhere.

Can anyone help???

Thanks TB
Old 02-04-2008, 04:44 PM
  #2  
NM2K
Senior Member
My Feedback: (14)
 
Join Date: Jan 2002
Location: Ringgold, GA
Posts: 11,488
Likes: 0
Received 2 Likes on 2 Posts
Default RE: Saito 100 No muffler preasure

The engine will run without muffler pressure.

It sounds like you either have a leak in the intake tract or there is a valve timing issue.

Check at the carb base or where the manifold enters the cylinder head for leaks. This assumes that the engine is timed properly and that the valves are operating when they are supposed to operate.

A timing error in reassembly will also cause no suction at the carb to exist. No suction, no fuel. Go over your timing again.


Ed Cregger
Old 02-04-2008, 04:47 PM
  #3  
w8ye
My Feedback: (16)
 
w8ye's Avatar
 
Join Date: Dec 2001
Location: Shelby, OH
Posts: 37,576
Received 7 Likes on 7 Posts
Default RE: Saito 100 No muffler preasure

It will not prime if the throttle is closed or the high speed needle is closed
Old 02-04-2008, 04:47 PM
  #4  
thunderbolts
Member
Thread Starter
 
Join Date: Nov 2005
Location: Northwich, UNITED KINGDOM
Posts: 49
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Saito 100 No muffler preasure

Thanks Ed.

I'll go over it again to make sure.

Many thanks TB
Old 02-04-2008, 06:20 PM
  #5  
thunderbolts
Member
Thread Starter
 
Join Date: Nov 2005
Location: Northwich, UNITED KINGDOM
Posts: 49
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Saito 100 No muffler preasure

Guys,

Timing is smack on. However the clearances on the tappets are not. the inlet side is OK (2 thou) but the exhaust has no clearence at all. None! I guess this means the exhaust side possibly never really closes properly. I have set it to 2 thou and will try again tomorrow.

TB
Old 02-04-2008, 07:20 PM
  #6  
XJet
Banned
 
Join Date: Mar 2003
Location: Tokoroa, , NEW ZEALAND
Posts: 3,848
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Saito 100 No muffler preasure

I assume you got the pushrods in the right way up ;-) If you put them in upside down then the valve clearances will disappear and they'll keep popping out of the rockers.
Old 02-05-2008, 03:32 PM
  #7  
thunderbolts
Member
Thread Starter
 
Join Date: Nov 2005
Location: Northwich, UNITED KINGDOM
Posts: 49
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Saito 100 No muffler preasure

Success!! Checked the timing again and it was fine. Reset the valve clearances, primed here up and she was away first flip. Set the mixtures up and I now have my swiss watch back!!!

Thanks for the advice guys.

TB
Old 02-05-2008, 04:06 PM
  #8  
blw
My Feedback: (3)
 
blw's Avatar
 
Join Date: Mar 2004
Location: Opelika, AL
Posts: 9,447
Likes: 0
Received 2 Likes on 2 Posts
Default RE: Saito 100 No muffler preasure

Glad you let us know, TB.
Old 02-05-2008, 04:08 PM
  #9  
thunderbolts
Member
Thread Starter
 
Join Date: Nov 2005
Location: Northwich, UNITED KINGDOM
Posts: 49
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Saito 100 No muffler preasure

Just one more thing. Is Xjet correct on the pushrods?? Do they have to be a particular way up?? Seems a little strange to me.

Thanks,

TB
Old 02-05-2008, 04:44 PM
  #10  
blw
My Feedback: (3)
 
blw's Avatar
 
Join Date: Mar 2004
Location: Opelika, AL
Posts: 9,447
Likes: 0
Received 2 Likes on 2 Posts
Default RE: Saito 100 No muffler preasure

Xjet is right. The pointed end goes under the rocker arms, inside the cup. Here is a pic of them:




Attached Thumbnails Click image for larger version

Name:	By76222.jpg
Views:	12
Size:	9.4 KB
ID:	870835  
Old 02-05-2008, 04:49 PM
  #11  
thunderbolts
Member
Thread Starter
 
Join Date: Nov 2005
Location: Northwich, UNITED KINGDOM
Posts: 49
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Saito 100 No muffler preasure

Great thanks for that.

Looks like I got it right. Just need another plane for the motor now!!!

TB

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.