Go Back  RCU Forums > RC Helicopters > Electric RC Helis > Helimax
Reload this Page >

Partial Pitch !!!!

Notices
Helimax This is for all your Helimax questions and comments.

Partial Pitch !!!!

Old 05-27-2008, 06:10 PM
  #1  
dltleth
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Lethbridge, AB, CANADA
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default Partial Pitch !!!!

Hi All,

Novice Numero Uno here - on the verge of committing my Axe CP to the next garage sale but I've spent my pension on parts !!!

I understand the principle's but can't get airborne and I think I know why.

When I increase throttle and the swash plate come's down, only one blade is affected as far as pitch is concerned. I've changed the linkage to no effect. Could the spindle be too tight???? I would have thought both sides would change symetrically??

Any (and all) help, much appreciated - thanks.

Dave

Old 05-28-2008, 04:23 PM
  #2  
Tall Paul
Senior Member
 
Join Date: Jun 2002
Location: Palmdale, CA
Posts: 5,211
Likes: 0
Received 1 Like on 1 Post
Default RE: Partial Pitch !!!!

All three servos should move in the same direction with the collective control.
Both blades should change pitch the same amount.
Hook up a 4-cell receiver battery to channel 5 to check this without the rotors turning. (much)
Work upward from the servo to the individual blade pitch controls if the servos work properly.
Old 05-28-2008, 06:03 PM
  #3  
dltleth
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Lethbridge, AB, CANADA
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Partial Pitch !!!!

Hi Sparky (?),

I've wrecked another Control Hub - new one should arrive in the a.m. All my linkages are correct - the plate level - all servo's operate good. When I reassemble the head, I'm gonna throw some 'grease' onto all the links and make the bugger work.

Thanks for your response.

Cheers,

Dave
Old 05-29-2008, 04:10 PM
  #4  
dltleth
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Lethbridge, AB, CANADA
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Partial Pitch !!!!

Hi Sparky,

Have re-built the head (correctly) and have applied some light grease to all appropriate connections/linkages.
On assembling the blade grips, I ensured that both sides of the spindle moved with no resistance.

However; I've put the Stabilizer Control Hub back on and connected all flybar links and the "other" linkages.

I have the swash plate and pitch in "neutral" - looks good, but.........

As soon as I apply throttle , all servo's operate to bring the s/plate down but only one blade (pitch) is being affected.

I have a fully charged (stock) battery each time I check the set up and the upper link (on that side) does not seem to be stuck.

When I move the flybar by hand, both blade grips move in unison - which is what they should do, right?

For whatever reason, when using the servo's, only one side will move (the same one each time). I'm beginning to think I have a manufacturing glitch ??? The only way this thing will fly is if I throw it.

Any idea's?

Dave
Old 05-29-2008, 07:42 PM
  #5  
Tall Paul
Senior Member
 
Join Date: Jun 2002
Location: Palmdale, CA
Posts: 5,211
Likes: 0
Received 1 Like on 1 Post
Default RE: Partial Pitch !!!!

I don't get much blade pitch change with the rotor stopped, and full travel on the control stick.
The flybar changes a lot though.
Holding the machine down with a moderate amount of collective, the rotor tilts properly in pitch and roll.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.