Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

Voltage sensor not working in Blue telemtry station

Old 08-15-2013, 09:01 AM
  #1  
stevenbryant
Junior Member
Thread Starter
 
Join Date: Aug 2013
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Voltage sensor not working in Blue telemtry station

Hi guys

i'm hoping someione can help me on a work around solution for the following problem, i am using the Aurora 9 handset and i'm using the HTS SS telemtry, i run the voltage sensor and amp sensor which have previously worked fine, i recently changed the ESC to one with out a UBEC and now the voltage sensor does not work. I have checked it on a ESC with a UBEC and all works fine. Looks to me as if the UBEC is require to create a circuit for the voltage sensor, can anybody help??


Thanks Steve
Old 08-16-2013, 01:14 AM
  #2  
A.T.
Senior Member
 
Join Date: Jul 2002
Location: Auckland, NEW ZEALAND
Posts: 2,581
Likes: 0
Received 1 Like on 1 Post
Default

Originally Posted by stevenbryant View Post
Hi guys
i'm hoping someione can help me on a work around solution for the following problem, i am using the Aurora 9 handset and i'm using the HTS SS telemtry,
i run the voltage sensor and amp sensor which have previously worked fine,
i recently changed the ESC to one with out a UBEC and now the voltage sensor does not work. I have checked it on a ESC with a UBEC and all works fine.
Looks to me as if the UBEC is require to create a circuit for the voltage sensor, can anybody help?? Thanks Steve
Plesae refer to the information and photos within:

. Telemetry - HTS-SS Advance, HTS-SS BLUE & HTS-Volt plus HTS_C50 or HTS-C200 Amp Sensor attachment.

. Telemetry - Battery Voltage via SPC and/or HTS-SS Blue or HTS-SS Advance for EP Models

e.g. ".Voltage not Displayed for GP Model or Opto BEC?
Hitec/MPX de advise:
"Connect a wire between negative battery wire and negative pin of receiver.
Pay attention that the wire is going to suppress the optocoupler protection of my opto HV esc
(galvanic break up)." see also preceding posts #19009 & #19012.
.pdf "HTS-Volt_Earth for GP & Opto BEC" of related Q&A posts is attached."

ex Hitec USA Support Forum Sticky:
Aurora 9, AFHSS 2.4Ghz Module, Transceivers_Receivers & Telemetry
- FAQ, Setups & Tips {Individual Links often updated}

Alan T.
Alan's Hobby, Model & RC FAQ Web Links

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.