Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

Aurura 9x losing memory on channels when switching from plane o plane

Old 07-11-2014, 08:49 AM
  #1  
BAS
Thread Starter
My Feedback: (28)
 
Join Date: Dec 2001
Location: Altoona, IA
Posts: 1,488
Likes: 0
Received 0 Likes on 0 Posts
Default Aurura 9x losing memory on channels when switching from plane o plane

I sent my brand new Aurora 9x transmitter into Hitec yesterday after talking to a service tech about he problem I have experienced. after programming 4 planes with one Optima 7 and 3 Optima 9 receivers into the radio and fying all the planes with no glitches. I went to switch from one plane to another a day later and on everyone had lost all the channel settings including servo elevators were reversed all endpoints were off and basically had to start from stratch on reprograming all my radios. The day 2 out of the 4 had the same issues. The tech suggested I send in the radio because he was hestitate on using this radio fearing it might act up in the air and crash a plane. I don't trust this radio all at this time and hope they can find a solution and just don't say we couldn't find anything wrong with it. I am sure I will be taken care of I have had excellent service from Hitec in the past. I am just upset because it is the middle of flying season and I was loving this radio so much. Just wondering if anyone else has experience this problem . I had all planes OFF the scan mode.
Old 09-22-2014, 07:26 AM
  #2  
rthalls
My Feedback: (63)
 
Join Date: Jun 2002
Location: richmond, IN
Posts: 174
Likes: 0
Received 0 Likes on 0 Posts
Default

having a problem with my aurora 9 draining the battery when not being used in the off position , any help or where to send it ?
Old 09-24-2014, 08:50 AM
  #3  
Texastbird
 
Texastbird's Avatar
 
Join Date: Jul 2002
Location: La Porte, TX
Posts: 1,217
Likes: 0
Received 2 Likes on 2 Posts
Default

http://hitecrcd.com/support/warranty-service
Old 11-11-2014, 06:16 PM
  #4  
Texastbird
 
Texastbird's Avatar
 
Join Date: Jul 2002
Location: La Porte, TX
Posts: 1,217
Likes: 0
Received 2 Likes on 2 Posts
Default

BAS, did they rectify your problem with your 9X?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.