Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

Aurora 9x erratic battery percentage readings on transmitter

Old 01-29-2015, 11:40 PM
  #1  
Ben Blest
Junior Member
Thread Starter
 
Join Date: Dec 2013
Location: Mobile Al
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default Aurora 9x erratic battery percentage readings on transmitter

Hi. My 9x is 8 months old. It has started giving erratic battery percentage remaining readings on tx. The percentage will jump up and down from10-20 % every couple seconds for no apparent reason. It will drop well below 50% after only 10-15 minutes of flying. However, the voltage seems to hold steady at 7.2 or better even when the meter says I have only 20-30% remaining. I took the battery and had it tested and it still had 7.4v while tx meter showed only 20% power remaining. Is there a problem with the radio, or is it the battery, or what? I lost a plane 2 weeks ago due to loss of signal. It went into failsafe for a couple seconds, Then went to full throttle and dove straight into the ground. I am afraid to use the radio now, please advise.
Old 02-24-2015, 08:28 AM
  #2  
nimrim
Junior Member
 
Join Date: Dec 2003
Location: Queen Creek, AZ
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default

What you have described is what happened to me. Fortunately my buzzer when off in time to land. I contacted Hitec service, they tell me that the 9x is to new they do not have replacement batteries and none will be available for another month. They recommended that I recycle the battery and see if that will correct the problem. Recycling the battery did not improve the outcome, Hitec recommended I go on line and find a RX battery that could be retrofitted to the radio. I have these options


  1. Do nothing and shelve the radio.
  2. Send the radio to Hitec service for a test or two and wait for a battery.
  3. Find a RX battery on line and hope it will fit.
  4. Purchase it with another radio from Hitec competition.

  5. All of the above




Have you found a battery that fits the radio compartment with the correct plug? Do you know what the two year warranty includes? Please Mr RC Universe I am not bashing anyone just looking for an answer.
Old 02-28-2015, 04:03 PM
  #3  
14MZ flyer
 
14MZ flyer's Avatar
 
Join Date: Jan 2005
Location: WarringtonCheshire, UNITED KINGDOM
Posts: 36
Likes: 0
Received 0 Likes on 0 Posts
Default

Hi Ben

Please read my thread, were you flying near any transmitter masts?
Old 03-01-2015, 08:13 PM
  #4  
wkevinm
 
Join Date: Sep 2004
Location: Calgary, AB, CANADA
Posts: 273
Likes: 0
Received 0 Likes on 0 Posts
Default

I never used the batteries that came with my 9 or 9x, replaced both with Lipo and never regretted it, a 2S 2000 Hyperian pack fits fine.
Old 05-17-2015, 12:25 AM
  #5  
Ben Blest
Junior Member
Thread Starter
 
Join Date: Dec 2013
Location: Mobile Al
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
Default

I was not flying near any transmitter masts, or towers or potential interference, always fly at the same field. I have a number of friends with the A9 and None of them have this problem. I am afraid this is a hardware or software issue specific to the A9x. I would appreciate a sincere and appropriate response from Hitec. I have called their tech support and get no real answers. They just told me not to use the percentage readings and use only the voltage readings. If the percentage readings are Not correct, then Hitec should Fix it! I bought Hitec's flagship radio expecting the best. Unfortunately, I am Not impressed with these issues and side stepping responses from hitec. It appears that I am not the only one.
Old 05-20-2015, 08:22 AM
  #6  
nimrim
Junior Member
 
Join Date: Dec 2003
Location: Queen Creek, AZ
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
Default

The issue with my 9X was solved, I hope, with a new battery. All manufacturers have had a problem with their RC products at some time on another, Hitec is no different than any of the other transmitters on the market. We could say they all hatched from the same egg give them two or three years their products will be updated their service center personnel will have turned over and we get to start all over. My original Hitec battery worked for a few months before my problem started. The battery would always take a full charge and test good, but could not hold the current in the radio and showed no sign of failure the current would suddenly drop and the unit would time out. The simple ease fix was to try a new battery, except Hitec does not have a replacement battery for the 9X, which has been on the market for a year. They checked the radio and it checked good and shipped it back to me nothing was done with the batteries. Not having a replacement battery did not concern them, Hitec recommended I find a replacement from one their competitors. I found an Airtronics TX LiPo from Hobby People which will fit into the case and so far it works. The voltage meters built into the 9X is questionable I do not trust the RX or TX readings and do not let the voltage drop under 75% and I top the battery off after two or three flying days which for my flying is OK. I'm sorry to say I bought a Futba before I found the answer, my Hitec is becoming a back up transmitter.


I apologize to RC Universe I mean no disrespect to their vendors or their site this is only intended to help solve an RC problem.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.