Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

HS5945 noise

Old 05-14-2002, 11:17 AM
  #1  
AV8TOR
Senior Member
Thread Starter
My Feedback: (2)
 
Join Date: Dec 2001
Location: Benbrook, TX
Posts: 427
Likes: 0
Received 0 Likes on 0 Posts
Default HS5945 noise

Mike I have a couple of HS5945's that I just installed and I want to find out if this is normal. I have no experience with digitals. I have heard that they sound different like a whine but should they do this at the neutral position? I get an almost Morse code intermittent whine sound regardless if the control rod is removed or on. I have also clicked up and down a few trim positions to see if it goes away and it does not. Is this it's normal zero position holding sound?
Old 05-14-2002, 07:53 PM
  #2  
MikeMayberry
Senior Member
My Feedback: (1)
 
MikeMayberry's Avatar
 
Join Date: Jan 2002
Location: Poway, CA
Posts: 3,531
Likes: 0
Received 0 Likes on 0 Posts
Default HS5945 noise

Yes it's normal... It's the sound of precision!

Mike.
Old 05-15-2002, 01:12 AM
  #3  
AV8TOR
Senior Member
Thread Starter
My Feedback: (2)
 
Join Date: Dec 2001
Location: Benbrook, TX
Posts: 427
Likes: 0
Received 0 Likes on 0 Posts
Default HS5945 noise

Nice to know then because so far I am very impressed with them. Great speed and strong. Thanks Mike

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.