Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

My Eclipse 7 Bit it today and bit my plane..

Old 06-05-2005, 05:27 PM
  #1  
drumbum
Senior Member
Thread Starter
My Feedback: (1)
 
drumbum's Avatar
 
Join Date: Jul 2004
Location: Lynchburg, VA
Posts: 1,834
Likes: 0
Received 0 Likes on 0 Posts
Default My Eclipse 7 Bit it today and bit my plane..

I got to the field today and went to fly my Jumping Jack electric. It was fairly hot out 88 Deg. (somehow i suspect this is part of my problem) well before take off i noticed an aileron was out of whack. so i went into program mode and it locked up. so i restarted the radio (off and on) turns out my fingers were on the model select 2 buttons.. the radio did not come on but could notice the LCD readout made a slight change like it tried. so i restarted it again. went into program mode. fixed the subtrim. then proceeded to fly the plane. after getting it up i had to trim ailerons and some down elevator. when i hit the elevator trim the beep just locked and i had ZERO control of my plane. i tried cutting it off and then back on before it hit the ground. I didnt have much time so i had to do it fast . well it stayed locked as the plane drilled into the ground at half throttle straight in. completely desroying the plane and a Thunder Power 2100 3s pack. i recreated the same thing 3 or 4 times at the field. but after getting home and the radio had been in the A/C for a while i cant recrate it...

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.