Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

HS605 dies, model too.

Old 06-12-2005, 06:43 PM
  #1  
John Hawkins
Senior Member
Thread Starter
My Feedback: (2)
 
John Hawkins's Avatar
 
Join Date: Jun 2003
Location: Halifax, NS, CANADA
Posts: 279
Likes: 0
Received 0 Likes on 0 Posts
Default HS605 dies, model too.

Yesterday I experienced the crash of my 1/5th scale T28 due to the failure of a Hitec HS605 on the elevator. It appears that the yellow wire from the pot broke away from the circuit board due to poor resitance to vibration. The loss of course hurts. While the model was a number of years old it was just starting on the fifth gallon of fuel through the ST2500. It appears that servo intended to replace the 605 have taken measures to withstand vibration. Would that I had known the problem. I have made what I hope is judged an objective review of what happened here and have posted it on my web site:
[link=http://rcalbum.rchomepage.com/Home.html]which is here and can be found on the left of the page[/link]

There is a video and then a look inside the servo.
Old 06-14-2005, 12:31 PM
  #2  
tohm
Senior Member
 
Join Date: May 2004
Location: Poway, CA
Posts: 188
Likes: 0
Received 0 Likes on 0 Posts
Default RE: HS605 dies, model too.

John,

Sorry to hear about what happened. If you would like the servo repaired please send it to the service dept.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.