Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

what's up with the slow turnaround?

Old 09-29-2005, 06:35 AM
  #1  
Senior Member
Thread Starter
My Feedback: (37)
 
Join Date: Jun 2003
Location: waukesha, WI
Posts: 772
Likes: 0
Received 0 Likes on 0 Posts
Default what's up with the slow turnaround?

I sent in 5 digital servos to be updated so I could use my futaba PCM receiver with them using a Y harness. Its been two weeks since hitec got them and when I call to check they keep telling me they will get to them soon. I thought turnaround was supposed to be 5 days?
Old 09-29-2005, 09:15 AM
  #2  
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Likes: 0
Received 1 Like on 1 Post
Default RE: what's up with the slow turnaround?

From the website:

Our goal is to ship your repair back out within 5 days from the day we get it. Unfortunately we cannot always accomplish this due to seasonal fluctuations in our workload. You can always contact our service department @ [email protected] or call (858) 748-8440 to find out just how long the current turnaround time is.
Old 09-29-2005, 09:35 AM
  #3  
Senior Member
Thread Starter
My Feedback: (37)
 
Join Date: Jun 2003
Location: waukesha, WI
Posts: 772
Likes: 0
Received 0 Likes on 0 Posts
Default RE: what's up with the slow turnaround?

Yes, I read that quote from the website. I actually called hitec a few days after i had sent my servos in. They had just received the package and quoted me a turnaround of "5 days". Now, it is 12 business days later and they tell me they will look at it soon. I just was curious if someone on the forum could clarify why the discrepancy.
Old 10-04-2005, 10:08 PM
  #4  
 
Join Date: Sep 2003
Location: de forest, WI
Posts: 674
Likes: 0
Received 1 Like on 1 Post
Default RE: what's up with the slow turnaround?

Hope you dont need a battery cover for your transmitter, I have been waiting for 6 weeks and still nothing.
Have been told twice they would send some out but I guess they are on back order from China???

Good luck on your servos....[&o]

Larry
Old 10-12-2005, 08:41 PM
  #5  
My Feedback: (11)
 
Join Date: Apr 2002
Location: Smithfield, VA
Posts: 1,056
Likes: 0
Received 0 Likes on 0 Posts
Default RE: what's up with the slow turnaround?

any new news?? have you gotten your servos back yet??

thanks
tony
Old 10-13-2005, 06:59 AM
  #6  
Senior Member
Thread Starter
My Feedback: (37)
 
Join Date: Jun 2003
Location: waukesha, WI
Posts: 772
Likes: 0
Received 0 Likes on 0 Posts
Default RE: what's up with the slow turnaround?

yes, I received them back about 4 weeks after sending them in. Now they have slop and I am contemplating sending them back. I haven't even used them yet.
Old 10-13-2005, 05:18 PM
  #7  
 
Join Date: Sep 2003
Location: de forest, WI
Posts: 674
Likes: 0
Received 1 Like on 1 Post
Default RE: what's up with the slow turnaround?

Humm, maybe the broken tranmitter battery covers that they said they would send out will show up soon

I placed a order looooong before you sent your servo's in. Still using Duct tape to hold them in.[:'(]

I'll keep looking in my mail box.

Hitec, are you listening to us out here?[]

Larry

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.