Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

hs 5645mg servo not centering?

Old 11-22-2005, 08:11 PM
  #1  
aerocom20
Member
Thread Starter
 
Join Date: Jul 2004
Location: sa, AUSTRALIA
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
Default hs 5645mg servo not centering?

Dear Hitec,

I seem to have a problem with one of my 5645 servos. Basically the servo is working fine and centers the flight control perfectly but when you turn the radio off and say wait 30 mins...when you turn the radio on again the servo will move slightly so now the flight control isn’t centered anymore. if you cycle the servo it will center on this new position. I have tried another receiver and the same thing happens. The servo is brand new with v1.04 software. I don’t have a servo programmer. Could you suggest what is wrong?
Thanks Adrian
Old 11-27-2005, 03:29 PM
  #2  
mglavin
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Likes: 0
Received 1 Like on 1 Post
Default RE: hs 5645mg servo not centering?

Whiles its plausible you have a BAD servo, lets eliminate some variables first.

Does or is your Tx saving the trim position when powered down?

Have you tried the servo on another channel to duplicate the offset?

Is a Tx "mix" in play, is this a slaved channel?

Is the problem realized with the servo connected to a surface only? Is binding present?
Old 11-29-2005, 10:48 PM
  #3  
aerocom20
Member
Thread Starter
 
Join Date: Jul 2004
Location: sa, AUSTRALIA
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hs 5645mg servo not centering?

Hi,
Thanks for the reply,
My TX does save the last know trim position when powered down. As I am setting up a new plane all my trims are at 0. The effected servo is mixed / slaved to the elevator channel. I tried the servo in another channel and the offset still happens. I put a new servo in place of the "faulty?" one and the elevator is centering perfectly. So i have verified the problem to this particular servo. This is my first experience with hitec digitals so I was just wondering if it was a possible “programming” fault.
Adrian
Old 11-29-2005, 10:59 PM
  #4  
mglavin
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Likes: 0
Received 1 Like on 1 Post
Default RE: hs 5645mg servo not centering?

When you suggest the offset still exists when coupled to another channel are you suggesting you set trim fro neutral, move the sticks around and all is well, power down and the servo is no longer centered in ths same location subsequent to powering down the the radio system?

Does your slaved channel support coupled trims, or do both channels/servos move when you trim? Many TX's do not? What TX are you using?
Old 11-29-2005, 11:14 PM
  #5  
aerocom20
Member
Thread Starter
 
Join Date: Jul 2004
Location: sa, AUSTRALIA
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hs 5645mg servo not centering?

Im using a JR 9x TX (Australian model number) The elevator slaving functions allow the trim to effect both servos. What the servo is doing....plug it into an unslaved standard channel, trims O, subtrim 0, ect. Move the tx stick around and the servo works perfectly, centers perfectly. power down the system..... now power it up again and the servo moves (about 1/16) and stops. move the tx stick around again and the servo follows the comands but it is centering on the new position (1/16 different to the first powerup)
Old 11-29-2005, 11:48 PM
  #6  
mglavin
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Likes: 0
Received 1 Like on 1 Post
Default RE: hs 5645mg servo not centering?

Sounds like the servo may have a problem... I'd suggest returning it for a replacement or send it in fro check-up.
Old 11-30-2005, 12:13 AM
  #7  
aerocom20
Member
Thread Starter
 
Join Date: Jul 2004
Location: sa, AUSTRALIA
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hs 5645mg servo not centering?

Thanks for you advise, I bought it from the states and just wanted to rule out all other options as i live in Australia.
Old 11-30-2005, 02:04 AM
  #8  
mglavin
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Likes: 0
Received 1 Like on 1 Post
Default RE: hs 5645mg servo not centering?

I'm confused by the idea that the servo centers perfectly at "0" trim initially and then later it’s offset. Reason is this normally is not the case as all servos simply do not center exactly out of the box due to design and electro-mechanical tolerances of the servos specifically and then of the TX's output signal. Let’s say your servo centers on 1505us and the TX outputs 1499, accordingly the servo obeys the TX and an offset is in play, typically the sub-trim is used to remove the offset. Enter Hitec Programmable Digitals, you have the ability to program the servo to react to the TX's output signal of 1499 with zero trim and place the servo arm perpendicular to the servo case...

It’s rare for ANY servo to center out of the box, to many variables...

The fact that your servos centers and then not is odd.
Old 12-03-2005, 10:23 PM
  #9  
aerocom20
Member
Thread Starter
 
Join Date: Jul 2004
Location: sa, AUSTRALIA
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hs 5645mg servo not centering?

Thanks for your help,
Tower sent out a replacement servo which was great. Just one more question.... The replacement 5645 servo is slightly different...It does NOT have the "+" stamped on the output shaft. The servo arms that i purchased from airwild were specifically suited for servos with the the "+". Could you please tell me what the difference is between the splines?
Old 12-06-2005, 11:32 AM
  #10  
mglavin
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Likes: 0
Received 1 Like on 1 Post
Default RE: hs 5645mg servo not centering?

The "+" indicated the gears were from an earlier second generation release... Current production gears do not have the "+" as you note.

Simply test fit the Airwild arm; there should not be a problem.
Old 12-08-2005, 04:57 AM
  #11  
aerocom20
Member
Thread Starter
 
Join Date: Jul 2004
Location: sa, AUSTRALIA
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hs 5645mg servo not centering?

Thanks the airwild arms fitted perfectly.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.