Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

Multiplex mini IPD 9channel problems

Old 08-05-2006, 04:39 PM
  #1  
Angus McDonald
Senior Member
Thread Starter
 
Join Date: Jun 2005
Location: Listowel, ON, CANADA
Posts: 236
Likes: 0
Received 0 Likes on 0 Posts
Default Multiplex mini IPD 9channel problems

Just bought a new Evo radio with a mini IPD 9 channel receiver, is there some kind of magic to get the receiver to work? The transmitter is working just fine with my JR receivers but I cant get the servos to even twitch with the new IPD (non synthizied) did I get a dud? any help would be appreciated.

Goose

P.S. Receiver channel 22, transmitter channel 22, battery 1/2 charged approx.
Old 08-06-2006, 03:02 AM
  #2  
mglavin
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Likes: 0
Received 1 Like on 1 Post
Default RE: Multiplex mini IPD 9channel problems

MPX crystal?

Are the servo connectors polarized corrrectly?
Old 08-06-2006, 08:39 AM
  #3  
Angus McDonald
Senior Member
Thread Starter
 
Join Date: Jun 2005
Location: Listowel, ON, CANADA
Posts: 236
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Multiplex mini IPD 9channel problems

Hi Michael, yes it's a MPX crystal in the receiver and the yellow wire from the MPX servos is in the signal location. I've tried the servos in my JR receiver and they rotate fine I've also set up a plane using the MPX transmitter and JR receiver it also works fine, Hmmmmmm

Angus
Old 08-06-2006, 11:21 AM
  #4  
mglavin
My Feedback: (31)
 
Join Date: Nov 2001
Location: Elverta, CA
Posts: 5,295
Likes: 0
Received 1 Like on 1 Post
Default RE: Multiplex mini IPD 9channel problems

It’s not possible you have the modulation shift feature set for NEGATIVE shift with this model set-up is it?

Where are the ATV/End-points values set at? If there set to high the IPD RX will not honor the request and initiate HOLD. With the EVO TX 100% End-point is 60 degrees servo angle. Comparatively JR requires a 150% and Futaba 140% setting for the same travel volume.

All that said you may have a bum RX, it happens.
Old 08-06-2006, 12:35 PM
  #5  
Angus McDonald
Senior Member
Thread Starter
 
Join Date: Jun 2005
Location: Listowel, ON, CANADA
Posts: 236
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Multiplex mini IPD 9channel problems

Michael, thanks for you helpful suggestions, I'm pretty sure it's a bum receiver. Positive shift is good and reduced all end point from 100% to 90% still nothing.

I'll contact Multiplex for warranty.

Thanks

Angus

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.