Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

Old 09-08-2010, 10:04 PM
  #1  
sportflyer-RCU
Thread Starter
My Feedback: (35)
 
Join Date: Feb 2002
Location: Vancouver, WA
Posts: 610
Likes: 0
Received 0 Likes on 0 Posts
Default Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

I have successfully made the conversion of Royal Multiplex Evo 9 to 2.4Ghz using the method described by Mike utilizing a Hitec Spectra 2.4 Ghz module.

The Firmware Revision of my Evo 9 is 1.5 .

I notice two things which behave differently after I made the conversion and bound the TX to the Optima 9 rcvr :

a) The TX no longer asks whether I want to turn on the RF ( The TX setting for this function is set to ON )

b) The TX no longer requests that the Throttle stick be moved to Idle position ( the TX setting for the function is set to ON)

Can you tell me whether this is normal after conversion to 2.4G ?

Everything else works as expected.

Thanks




Old 09-08-2010, 10:54 PM
  #2  
MikeMayberry
Senior Member
My Feedback: (1)
 
MikeMayberry's Avatar
 
Join Date: Jan 2002
Location: Poway, CA
Posts: 3,531
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

I'll have to look into this. I would suggest you update to the Pro software v1.63.

Mike.
Old 09-08-2010, 11:30 PM
  #3  
sportflyer-RCU
Thread Starter
My Feedback: (35)
 
Join Date: Feb 2002
Location: Vancouver, WA
Posts: 610
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

Do I have to send the radio in for this update or can I download the firmware and update using Evo data manager? Tks
Old 09-09-2010, 09:39 AM
  #4  
Brendan Lugo
Senior Member
 
Brendan Lugo's Avatar
 
Join Date: Nov 2004
Location: Poway, CA
Posts: 675
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

For the Evo Pro V2.62 software update, send it in. There is also a minor hardware addition for the slider channels.
Old 09-09-2010, 09:48 AM
  #5  
sportflyer-RCU
Thread Starter
My Feedback: (35)
 
Join Date: Feb 2002
Location: Vancouver, WA
Posts: 610
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

I found why the message " Move stick to Idle " is missing. ( issue b above).

The message has been replaced by " Throttle Cut active" . This happened when I changed the throttle cut function from momentary to toggle .

So the only issue left is issue a) .......After binding , I dont get the message to turn on RF when TX is first turned on.
Old 09-09-2010, 09:51 AM
  #6  
sportflyer-RCU
Thread Starter
My Feedback: (35)
 
Join Date: Feb 2002
Location: Vancouver, WA
Posts: 610
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

Brendan, is the firmware update 1.63( per Mike) or 2.63 ? Will the 2.4G conversion still work after making the firmware changes? Tks
Old 09-09-2010, 10:26 AM
  #7  
Brendan Lugo
Senior Member
 
Brendan Lugo's Avatar
 
Join Date: Nov 2004
Location: Poway, CA
Posts: 675
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

ORIGINAL: sportflyer-RCU

Brendan, is the firmware update 1.63( per Mike) or 2.62 ? Will the 2.4G conversion still work after making the firmware changes? Tks
2.62 is the pro software. Mike typo'd in his above post. This is the last software version that will still work with aftermarket modules in the radio. Anything above this will only work with multiplex 2.4 module which is not available in the states.
Old 09-09-2010, 10:32 AM
  #8  
Brendan Lugo
Senior Member
 
Brendan Lugo's Avatar
 
Join Date: Nov 2004
Location: Poway, CA
Posts: 675
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module


ORIGINAL: sportflyer-RCU

I found why the message '' Move stick to Idle '' is missing. ( issue b above).

The message has been replaced by '' Throttle Cut active'' . This happened when I changed the throttle cut function from momentary to toggle .

So the only issue left is issue a) .......After binding , I dont get the message to turn on RF when TX is first turned on.

The RF section (with the conversion) is in the module itself and no longer part of the main board circuitry and channel check before RF is outputted which is why that prompt will dissapear.
Old 09-09-2010, 04:36 PM
  #9  
sportflyer-RCU
Thread Starter
My Feedback: (35)
 
Join Date: Feb 2002
Location: Vancouver, WA
Posts: 610
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module


ORIGINAL: Brendan Lugo


ORIGINAL: sportflyer-RCU

I found why the message '' Move stick to Idle '' is missing. ( issue b above).

The message has been replaced by '' Throttle Cut active'' . This happened when I changed the throttle cut function from momentary to toggle .

So the only issue left is issue a) .......After binding , I dont get the message to turn on RF when TX is first turned on.

The RF section (with the conversion) is in the module itself and no longer part of the main board circuitry and channel check before RF is outputted which is why that prompt will dissapear.
In other words my issue a) in really a non issue because that's the expected behavior after conversion. Tks
Old 09-10-2010, 10:15 AM
  #10  
Brendan Lugo
Senior Member
 
Brendan Lugo's Avatar
 
Join Date: Nov 2004
Location: Poway, CA
Posts: 675
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Different behavior after Converting Evo 9 to 2.4Ghz using Spectra module

Yup, it's a non issue. [8D]

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.