Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > HPI Racing
Reload this Page >

Found an old Firestorm 10T in my garage

Notices
HPI Racing HPI Racing forum. Discuss all HPI Racing products here.

Found an old Firestorm 10T in my garage

Old 07-11-2020, 10:35 AM
  #1  
Rhizzlebop
Thread Starter
 
Join Date: Nov 2006
Location: Columbia, SC
Posts: 219
Likes: 0
Received 0 Likes on 0 Posts
Default Found an old Firestorm 10T in my garage

I bought this thing back in nov 2009. For some reason back then I changed the motor to a mamba max pro 4600 kv.

I remember driving it on very very sandy roads near the beach and the motor started jumping and skipping and wouldnít go.

Well soon after I met my now wife then later two kids happened and today I pulled out the box with this thing in it.

Id like to restart my interest in the hobby and start to involve my two young boys. Not sure what to do with it.

I know now nothing about motor KV 3800 4800 etc. donít know what esc is in it but ii can check. Probably stock esc.

I think i got got rid of the battery years ago due to fear of it sitting aro7nd for years in who knows what charge condition. I had bought some monster 8 amp battery but I forgot what voltage or cell count I bought.

Would it be likely the motor is toast toast or is it repairable or worth repair effort?

if itís best to get a new motor which is recommended? Donít want to spend a bunch on this old firestorm. Not even sure I can get parts for 11 year old firestorm.

I also found my cellpro charger charger that I donít remember how it works but I had a power supply and some plug board for it. It did some5hing about cell balanci g.

Or or is this stuff too old and I should just toss it and get something new?

I remember it was fast.

Help suggestions appreciated. And please be clear to this older guy. I know near nothing now about these lips cells and 2S 3S etc or these motor speeds 3800 4800 5700. No idea what it means or whatís needed to work.

I also do do not recall if I changed the gear in the back or no5 but if it helps suggestions I can check.
Old 07-11-2020, 11:17 AM
  #2  
Rhizzlebop
Thread Starter
 
Join Date: Nov 2006
Location: Columbia, SC
Posts: 219
Likes: 0
Received 0 Likes on 0 Posts
Default

Just reread my thread from 11 years ago confirming that I installed a mamba max pro esc and 4600 castle motor. I don’t have a big lips now to test if it even turns on. If it does then not sure what messed up years ago if it’s the motor or esc. I recall it was jumping and glitching sort of.
Old 07-14-2020, 05:32 AM
  #3  
Rhizzlebop
Thread Starter
 
Join Date: Nov 2006
Location: Columbia, SC
Posts: 219
Likes: 0
Received 0 Likes on 0 Posts
Default

Any thoughts on what motor would fit best here? At 5his point I do need to buy a new battery so can go 2 or 3 cell.

I see some some fairly inexpensive “SCT” motors on line. Not sure if that’s compatible 2ith the mamba max pro from 2009.

Thoughts?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.