Notices
JetCat Turbine Direct Support Ask your JetCat questions here for the experts that know them. MrMatt and Bob Wilcox will field your inquiries.

90RXI help

Old 06-28-2019, 05:17 PM
  #1  
jcterrettaz
Thread Starter
 
jcterrettaz's Avatar
 
Join Date: Jul 2007
Location: Carp, ON, CANADA
Posts: 306
Likes: 0
Received 0 Likes on 0 Posts
Default 90RXI help

Was flying my Rookie for two minute and the turbine stop.. landed safely then ground unit said : E C .. temperature error? why? the the temperature probe is damaged?
The little Jet Cat board in the jet flash non stop to.
And if I have to send the turbine to be check where is the place in the US?
Thanks in advance
Old 06-28-2019, 08:46 PM
  #2  
Dave Wilshere
 
Join Date: Jun 2002
Location: Watford, UNITED KINGDOM
Posts: 11,175
Likes: 0
Received 35 Likes on 33 Posts
Default

Could be the temperature probe died. You can change it yourself, two screws.
Turbine still spins? Everything looks OK otherwise?
Order a P-80 —P160 probe from DW. Use the Nylon mount from your turbines probe. When you re fit calibrate the temp again and you are good to go
Old 06-28-2019, 11:48 PM
  #3  
CARS II
My Feedback: (7)
 
CARS II's Avatar
 
Join Date: Oct 2002
Location: Sacramento CA
Posts: 5,244
Received 3 Likes on 3 Posts
Default



I'm getting the same massage but my situation is a bit different.

Making sure the cable wasn't faulty, I tested with another cable getting the same results then I plugged in my P60 to the comm cable and, sure enough, I got temp reading, I'm also getting the rapid flashing light.

I ordered a new temp prob from DW, about $60, like Dave said, simple to change.

Dave knows how to calibrate the new temp prob, I also have it if you need to know how, very easy steps to fallow.

Last edited by CARS II; 06-28-2019 at 11:59 PM.
Old 06-29-2019, 03:35 AM
  #4  
jcterrettaz
Thread Starter
 
jcterrettaz's Avatar
 
Join Date: Jul 2007
Location: Carp, ON, CANADA
Posts: 306
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks for the help, one of my friend will give me a new probe . Yes Dave the turbine look fine otherwise .
Look like an easy fix ...
Now where you send Jet Cat for service in the US ( nothing in Canada) ?
Old 06-29-2019, 07:53 AM
  #5  
jcterrettaz
Thread Starter
 
jcterrettaz's Avatar
 
Join Date: Jul 2007
Location: Carp, ON, CANADA
Posts: 306
Likes: 0
Received 0 Likes on 0 Posts
Default

Always learning...the ATV on my Rookie touch the sensor when I apply rudder and disconnect the 3 pins. Was easy to remove the cover with a special screwdriver . So well made inside ...
Made the sensor closer to the turbine body...everything work again
Thanks
Old 06-29-2019, 11:36 AM
  #6  
CARS II
My Feedback: (7)
 
CARS II's Avatar
 
Join Date: Oct 2002
Location: Sacramento CA
Posts: 5,244
Received 3 Likes on 3 Posts
Default

Very nice! At least we know now for sure that the massage was because the temp prob wasn't working ( disconnected)

If your JetCat turbine is in need of service, send it to George at DreamWorks, before you send it, you have to fill up a request for repairs form, it's all on their website.

You'll also find some JetCat parts on their site.

Last edited by CARS II; 06-29-2019 at 11:39 AM.
Old 06-29-2019, 03:53 PM
  #7  
jcterrettaz
Thread Starter
 
jcterrettaz's Avatar
 
Join Date: Jul 2007
Location: Carp, ON, CANADA
Posts: 306
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks you for the info's Carlos
the 90RX as only 20 minutes running time , everything is new and work fine, but I have an old Titan who will need service at the end of this year.
Old 06-29-2019, 07:54 PM
  #8  
CARS II
My Feedback: (7)
 
CARS II's Avatar
 
Join Date: Oct 2002
Location: Sacramento CA
Posts: 5,244
Received 3 Likes on 3 Posts
Default

Very nice!

Here is where I fly.

Have fun, be safe
Old 07-02-2019, 01:30 PM
  #9  
jcterrettaz
Thread Starter
 
jcterrettaz's Avatar
 
Join Date: Jul 2007
Location: Carp, ON, CANADA
Posts: 306
Likes: 0
Received 0 Likes on 0 Posts
Default

I fly yesterday and the 90RXI Jet Cat was perfect , I can't post video the role are not accepted?!
Im very please with the throttle response and very powerful for a 90
Old 07-02-2019, 04:37 PM
  #10  
CARS II
My Feedback: (7)
 
CARS II's Avatar
 
Join Date: Oct 2002
Location: Sacramento CA
Posts: 5,244
Received 3 Likes on 3 Posts
Default

Thanks for the report

Enjoy

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.