Notices
JetCat Turbine Direct Support Ask your JetCat questions here for the experts that know them. MrMatt and Bob Wilcox will field your inquiries.

P300rx

Old 11-26-2020, 10:19 AM
  #1  
mhpverheggen
Thread Starter
My Feedback: (22)
 
Join Date: Jul 2005
Location: Ft. Lauderdale FL
Posts: 66
Received 0 Likes on 0 Posts
Default P300rx

I got the “no pump” message. According the manual it means no pump connected or a defective pump cable. I tried with a new pump cable with no luck.
Anybody has any idea what else could it be?
Old 11-26-2020, 10:26 AM
  #2  
Dave Wilshere
 
Join Date: Jun 2002
Location: Watford, UNITED KINGDOM
Posts: 12,172
Likes: 0
Received 330 Likes on 254 Posts
Default

You have tried both sets of sockets on the pump and you are sure the square plug is the correct sense with the tag on the hook?
Old 11-26-2020, 10:36 AM
  #3  
mhpverheggen
Thread Starter
My Feedback: (22)
 
Join Date: Jul 2005
Location: Ft. Lauderdale FL
Posts: 66
Received 0 Likes on 0 Posts
Default

Yes I did,
it appeared when I wanted to start the engine for the 3th flight of the day. Bat voltage was good.
could it be that it has an issue with the little “motherboard” in the pump?

Last edited by mhpverheggen; 11-26-2020 at 10:45 AM.
Old 11-26-2020, 01:52 PM
  #4  
Dave Wilshere
 
Join Date: Jun 2002
Location: Watford, UNITED KINGDOM
Posts: 12,172
Likes: 0
Received 330 Likes on 254 Posts
Default

Had the pump possibly jammed with something causing an over current? I presume the pump does not prime now even though it says No pump? Test Function check.
Old 11-26-2020, 04:46 PM
  #5  
mhpverheggen
Thread Starter
My Feedback: (22)
 
Join Date: Jul 2005
Location: Ft. Lauderdale FL
Posts: 66
Received 0 Likes on 0 Posts
Default

It might be jammed, I’ll have to check. I did try the prime function but no luck. The green light on the pump is on though so it does receive power I assume?
Old 11-26-2020, 10:00 PM
  #6  
Dave Wilshere
 
Join Date: Jun 2002
Location: Watford, UNITED KINGDOM
Posts: 12,172
Likes: 0
Received 330 Likes on 254 Posts
Default

You could try taking the pump out and forcing fuel through the gears from the out side, see if anything moves or comes out of the in side.
Yes, the green light would say power is getting to the board. How many hours approx on the pump?
Old 11-27-2020, 08:11 AM
  #7  
mhpverheggen
Thread Starter
My Feedback: (22)
 
Join Date: Jul 2005
Location: Ft. Lauderdale FL
Posts: 66
Received 0 Likes on 0 Posts
Default

It is fixed. I had to reprogram the unit for fuel pump and do an engine start. (Hold the “change value” during electrical power-up. Select “fuel pump”. The “no pump” message remains until you do an engine start).
Old 11-27-2020, 08:17 AM
  #8  
Dave Wilshere
 
Join Date: Jun 2002
Location: Watford, UNITED KINGDOM
Posts: 12,172
Likes: 0
Received 330 Likes on 254 Posts
Default

So it was OC no pump.
Old 11-27-2020, 08:41 AM
  #9  
mhpverheggen
Thread Starter
My Feedback: (22)
 
Join Date: Jul 2005
Location: Ft. Lauderdale FL
Posts: 66
Received 0 Likes on 0 Posts
Default

Hi Dave,

im not familiar with “OC”?
Old 11-27-2020, 11:13 AM
  #10  
Dave Wilshere
 
Join Date: Jun 2002
Location: Watford, UNITED KINGDOM
Posts: 12,172
Likes: 0
Received 330 Likes on 254 Posts
Default

Off Condition. That will stay until the next run
Old 11-27-2020, 11:43 AM
  #11  
mhpverheggen
Thread Starter
My Feedback: (22)
 
Join Date: Jul 2005
Location: Ft. Lauderdale FL
Posts: 66
Received 0 Likes on 0 Posts
Default

Ah ok. When it first appeared I was not able to start the engine. After I did the “procedure” it worked again.

Thanks for your help Dave.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.