Notices
JetCat Turbine Direct Support Ask your JetCat questions here for the experts that know them. MrMatt and Bob Wilcox will field your inquiries.

V-10 ecu problem

Old 12-02-2022, 12:15 PM
  #1  
Captainbob
Thread Starter
My Feedback: (4)
 
Join Date: Dec 2001
Location: Dayton, OH
Posts: 358
Likes: 0
Received 0 Likes on 0 Posts
Default V-10 ecu problem

I have a T-45 Hawk with a P-140 with internal fuel pump and fuel control. Recently i had to rebuild the Hawk program in my TX. Went normal except for the throttle control (didnt work). I suspected i needed to re-teach the throttle limits to the ECU. But i can't get through the procedure, somewhere around "set throttle to max."......the handheld unit locks up. I'm using the throttle/trim start procedure not the aux switch.
The message on the GSU says.........."overcurrent"...... Please help.
Old 12-02-2022, 03:17 PM
  #2  
Dave Wilshere
 
Join Date: Jun 2002
Location: Watford, UNITED KINGDOM
Posts: 12,749
Received 600 Likes on 434 Posts
Default

1st with everything plugged in and switch on, if you hit the spool button does the turbine spin over? Over Current is exactly what it says, but it means something is (or thinks) it’s drawing 20-30A !
Normally it’s the red/yellow/black cable, I presume it’s got the yellow end with 90 degree plug? If not order new leads and toss the original in the trash
Old 12-03-2022, 08:17 AM
  #3  
Captainbob
Thread Starter
My Feedback: (4)
 
Join Date: Dec 2001
Location: Dayton, OH
Posts: 358
Likes: 0
Received 0 Likes on 0 Posts
Default

Dave, the engine spins normally when spool button is pushed.
Old 12-03-2022, 10:13 AM
  #4  
Dave Wilshere
 
Join Date: Jun 2002
Location: Watford, UNITED KINGDOM
Posts: 12,749
Received 600 Likes on 434 Posts
Default

OK, makes no sense the Rc side would show over current.
The throttle patch lead is good? Definitely plugged cleanly into the three pins for throttle on the ECU?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.