Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic > JetCat Turbine Direct Support
Reload this Page >

120SX shooting flames on start

Notices
JetCat Turbine Direct Support Ask your JetCat questions here for the experts that know them. MrMatt and Bob Wilcox will field your inquiries.

120SX shooting flames on start

Old 07-03-2010, 05:43 PM
  #1  
kkling77
Thread Starter
My Feedback: (16)
 
Join Date: Oct 2004
Location: Laurel, MD
Posts: 138
Likes: 0
Received 0 Likes on 0 Posts
Default 120SX shooting flames on start

I have a new 120SX (only about 7 flights on it) that is shooting a couple of flames out during start up. Could somebody tell me what I need to change so this will not continue happening. I'm guessing there is a setting to reduce initial fuel flow during start(?) I'm new to jets so any help would be greatly appreciated. Thanks.
Old 07-03-2010, 05:47 PM
  #2  
KC36330
 
Join Date: Apr 2006
Location: Enterprise, AL
Posts: 5,962
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 120SX shooting flames on start

any kerosene start will shoot short warm (yellow) flames on start up.
Old 07-03-2010, 08:04 PM
  #3  
kkling77
Thread Starter
My Feedback: (16)
 
Join Date: Oct 2004
Location: Laurel, MD
Posts: 138
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 120SX shooting flames on start

Okay, thanks for the heads up. Still new to the jet game so I wasn't sure if this was normal or not.
Old 07-04-2010, 03:25 AM
  #4  
BaldEagel
 
BaldEagel's Avatar
 
Join Date: Oct 2005
Location: Kent, UNITED KINGDOM
Posts: 9,665
Received 4 Likes on 4 Posts
Default RE: 120SX shooting flames on start

You can reduce the amount of flame comming out to practically nothing by following the instructions in the manual for priming the kero start fuel line, as the 120SX pump breaks in you may have to adjust this again to ensure you only get a couple of drips of fuel comming out of the start line every second or so, this has worked on my 120SX to prevent flaming, but as KC says you will always get some small flame out of the turbine during the start up phase, but it should only be small.

Mike
Old 08-08-2010, 01:12 PM
  #5  
rcand
Senior Member
 
Join Date: Jul 2002
Location: coral springs, FL
Posts: 434
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 120SX shooting flames on start

I would call Bob Wilcox or Scott and see what they say. My 160sx does not have any flame on the start, none that I have noticed.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.