RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   JetCat Turbine Direct Support (https://www.rcuniverse.com/forum/jetcat-turbine-direct-support-151/)
-   -   P300rx (https://www.rcuniverse.com/forum/jetcat-turbine-direct-support-151/11685135-p300rx.html)

mhpverheggen 11-26-2020 10:19 AM

P300rx
 
I got the “no pump” message. According the manual it means no pump connected or a defective pump cable. I tried with a new pump cable with no luck.
Anybody has any idea what else could it be?

Dave Wilshere 11-26-2020 10:26 AM

You have tried both sets of sockets on the pump and you are sure the square plug is the correct sense with the tag on the hook?

mhpverheggen 11-26-2020 10:36 AM

Yes I did,
it appeared when I wanted to start the engine for the 3th flight of the day. Bat voltage was good.
could it be that it has an issue with the little “motherboard” in the pump?

Dave Wilshere 11-26-2020 01:52 PM

Had the pump possibly jammed with something causing an over current? I presume the pump does not prime now even though it says No pump? Test Function check.

mhpverheggen 11-26-2020 04:46 PM

It might be jammed, I’ll have to check. I did try the prime function but no luck. The green light on the pump is on though so it does receive power I assume?

Dave Wilshere 11-26-2020 10:00 PM

You could try taking the pump out and forcing fuel through the gears from the out side, see if anything moves or comes out of the in side.
Yes, the green light would say power is getting to the board. How many hours approx on the pump?

mhpverheggen 11-27-2020 08:11 AM

It is fixed. I had to reprogram the unit for fuel pump and do an engine start. (Hold the “change value” during electrical power-up. Select “fuel pump”. The “no pump” message remains until you do an engine start).

Dave Wilshere 11-27-2020 08:17 AM

So it was OC no pump.

mhpverheggen 11-27-2020 08:41 AM

Hi Dave,

im not familiar with “OC”?

Dave Wilshere 11-27-2020 11:13 AM

Off Condition. That will stay until the next run

mhpverheggen 11-27-2020 11:43 AM

Ah ok. When it first appeared I was not able to start the engine. After I did the “procedure” it worked again.

Thanks for your help Dave.


All times are GMT -8. The time now is 11:17 PM.


Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.