RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   JetCat Turbine Direct Support (https://www.rcuniverse.com/forum/jetcat-turbine-direct-support-151/)
-   -   JETI Jetcat Telemetry (https://www.rcuniverse.com/forum/jetcat-turbine-direct-support-151/11701211-jeti-jetcat-telemetry.html)

GBR55 08-07-2022 06:31 AM

JETI Jetcat Telemetry
 
I have a 10 hour JetCat 180RX with V10 ECU and set up the V1.1 JetCat telemetry adaptor running through a CB210 central box and 2 REX3 receivers . I also have a mini GSU mounted in parallel using a third ribbon cable to the i/o board . JETI DC16 TX and airborne RX/CB have latest JETI firmware .My GSU says the telemetry version is 8.6. I cannot identify the ECU version which from manual is meant to be 10.3 minimum. As this is a used turbine I do not have anything that tells me the ECU firmware version and canít seem to find it on the ECU or on the shipping box.

The TX screen shows all my normal GSU data when powered up. I can spool the starter and get a reading on the TX screen along with appropriate run state; but when I initiate start the TX screen JetCat readout boxes start flashing and continue flashing until the RX is turned off. The mini GSU works perfectly throughout all this and I just go fly. I have ran the same setup with mini GSU disconnected and got the same flashing screen on start initiation. I have switched cable positions on the i/o board but it makes no difference . Flash flash flash until RX turned off.

I have previously used VSpeak on my 120SX with V6.xxx but had to jump through the Applications / JetiBox menus with a bunch of keystrokes each time I powered up for start. Not really convenient in the 21st century.

I went to JetCat Telemetry thinking it would be seamless.

Please help

Thanks
GBR55


GBR55 08-08-2022 03:52 PM

A little update to the- so far- silent readers

I Disconnected i/o board and mini gsu and Telemetry works on TX windows when the sensor ribbon is plugged direct into ecu. I get full start information on the TX screen and telemetry throughout the run.

I then tried bussing the i/o board on the telemetry unit with a seperate cable to the i/o. As soon as I initiated the start it commenced flashing again. I cycled up through idle run and cooling and then shut down . Removed i/o cable and started it . When idle established I plugged i/o in and it continued to read properly right through to shutdown / cooling

So it appears to be a start up power draw issue.I do not see less than 9.5V on my 3s Life 4200 mah even with ignition pump and starter running start sequence and it will sit on 10V after start. All normal on my 3 JetCats
.

The JetCat manual shows the i/o bus connecting to the ecu and the i/o board as connection point for telemetry but on mine it appears to be the opposite.

It may be an ecu firmware update required and I will try to find out how to discover what ecu version I have from JC next week

In the meantime I will see what it takes to get my VSpeak on this ECU 10

The good news is that it hasnít stopped me from flying

GBR55

LA jetguy 08-08-2022 09:32 PM

Glad the recommendations worked.. possibly the telemetry module needs to be looked at and not require so much power to function properly..

David (Jonathan’s Jeti friend)

GBR55 08-09-2022 04:49 AM

Thanks LAjetguy!

LA jetguy 08-09-2022 09:12 PM

You are welcome 👍


All times are GMT -8. The time now is 04:15 PM.


Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.