Notices
JR Radio & Spektrum Radios Discuss all your JR and Spektrum gear.

388S TX Lithium Battery gone flat

Old 05-03-2013, 04:36 AM
  #1  
123Cat
Thread Starter
 
Join Date: Oct 2005
Location: ACTAustralia, AUSTRALIA
Posts: 391
Likes: 0
Received 0 Likes on 0 Posts
Default 388S TX Lithium Battery gone flat


My internal lithium battery gave a message of going flat if I recall

and now the whole TX wont come on with a fully charged main battery ,



do I have to replace the internal lithium battery ?
Old 05-03-2013, 10:11 AM
  #2  
Rafael23cc
My Feedback: (6)
 
Rafael23cc's Avatar
 
Join Date: May 2002
Location: Junction City, KS
Posts: 2,958
Likes: 0
Received 4 Likes on 4 Posts
Default RE: 388S TX Lithium Battery gone flat

I had an 8103 that the internal battery went flat. If I recall correctly, the transmitter turned on, I just did not have any of my saved programming. You might have an additional issue going on. Have you checked if you have an internal fuse?

To answer your question, if you know your battery was going dead, yes, you should plan for a replacement.

Rafael
Old 05-03-2013, 01:16 PM
  #3  
123Cat
Thread Starter
 
Join Date: Oct 2005
Location: ACTAustralia, AUSTRALIA
Posts: 391
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 388S TX Lithium Battery gone flat

Thanks will check inside , I want to use it for the free heli Sim

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.