Notices
JR Radio & Spektrum Radios Discuss all your JR and Spektrum gear.

Wrong Crystal?

Old 07-12-2002, 06:06 PM
  #1  
Thread Starter
My Feedback: (8)
 
Join Date: Dec 2001
Location: St.Charles, MO
Posts: 2,819
Received 17 Likes on 13 Posts
Default Wrong Crystal?

In April I sent in a 940 and a 945 receiver to be tuned specifically to my 10X transmitter module on channel 15. Last week, while using the 940 on a turbine test bench, my local RAM rep noticed that it had a gray colored crystal in it and said he didn't know how the receiver was working since it is a dual conversion receiver and the gray crystals are for single conversion receivers. Sure enough, when I got home I checked the 945 which is mounted in a JMP T-33, it has a red one which I understand is the correct one.

If the gray one is a single conversion crystal, why would Horizon return that receiver with the wrong crystal and, more to the point, how can they do the requested fine tuning with a single conversion crystal in a dual conversion receiver?
Old 07-12-2002, 07:45 PM
  #2  
 
dsnyder's Avatar
 
Join Date: Jun 2002
Location: Champaign, IL
Posts: 9,365
Likes: 0
Received 1 Like on 1 Post
Default Wrong Crystal?

Could you please give us a call so we can research the specific repair, find out who did the repair, and find any repair notes we may have to investigate how this happend. This way we can be sure it does not happen again. If you can, please give our product support department a call toll free at 877-504-0233 at your convience.
Old 07-12-2002, 08:31 PM
  #3  
Thread Starter
My Feedback: (8)
 
Join Date: Dec 2001
Location: St.Charles, MO
Posts: 2,819
Received 17 Likes on 13 Posts
Default Wrong Crystal?

I called and worked this out with Randy at Horizon. It appears that I was sold the wrong crystal from one of the hobby shops that I use. He is sending me the correct crystal in return for the incorrect one I wll send back to Horizon.
Old 07-12-2002, 08:57 PM
  #4  
 
dsnyder's Avatar
 
Join Date: Jun 2002
Location: Champaign, IL
Posts: 9,365
Likes: 0
Received 1 Like on 1 Post
Default Wrong Crystal?

Sorry you had a problem, but I hope we can get it all straightened out for you. Thanks!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.