Notices
JR Radio & Spektrum Radios Discuss all your JR and Spektrum gear.

AR-9000 problem...

Old 02-25-2008, 09:24 AM
  #1  
kirkj
Thread Starter
My Feedback: (61)
 
Join Date: Sep 2002
Location: spring, TX
Posts: 494
Likes: 0
Received 0 Likes on 0 Posts
Default AR-9000 problem...

I have an AR-9000 installed in a jet, using both remote antennas. about 30% of the time when i turn on the power, the light on the internal RX (the one which has an antenna coming out the side of the case) flickers randomly. when checked with the flight log it shows many (100+) fades along with high fades on all other antennas, frame losses and usually a hold or 2. all this with my 10X - w/spektrum module 2 feet away.
i can do nothing except cycle power, and the lights all come on solid with an un-eventfull flight followed by excellent flight log numbers.

any ideas? i really feel dumb for even flying it and its now grounded till a solution is reached.
Old 02-25-2008, 09:53 AM
  #2  
dsnyder
 
dsnyder's Avatar
 
Join Date: Jun 2002
Location: Champaign, IL
Posts: 9,365
Likes: 0
Received 1 Like on 1 Post
Default RE: AR-9000 problem...

For piece of mind, I would recommend sending the module and the receiver in for a check up.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.