Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic > Merlin Turbine Clinic
Reload this Page >

Merlin 140 does not idle at 35K.

Notices
Merlin Turbine Clinic Support for Merlin Turbines is provided in this forum

Merlin 140 does not idle at 35K.

Old 04-02-2013, 05:30 AM
  #1  
mjunior
Thread Starter
 
Join Date: Nov 2004
Location: Sao Jose dos CamposSP, BRAZIL
Posts: 269
Likes: 0
Received 1 Like on 1 Post
Default Merlin 140 does not idle at 35K.

Buddies,

I've just bought a brand new Merlin 140 (still the version with external valves) and tested it this past weekend. In general it performed very well with several successful starters and excellent spool up. However, during all tests it only idled at 40~41K and not at 35K. I've checked all parameters in the ECU and everything is ok. I'm using a JR 12X transmitter.

Any ideas?
Old 04-02-2013, 09:03 AM
  #2  
lov2flyrc
My Feedback: (24)
 
lov2flyrc's Avatar
 
Join Date: Dec 2001
Location: Daytona Beach
Posts: 6,102
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Merlin 140 does not idle at 35K.

If you have confirmed the idle RPM in the ECU is set to 35K (as it should be) then you just need to let the engine idle for a few minutes to calibrate the ECU to the pump. It will slowly reduce pump voltage until idle RPM is reached. If you are testing on a stand, then install in an airframe, the ECU will need to recalibrate itself again due to the added restrictions of the airframe install.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.