Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic > Merlin Turbine Clinic
Reload this Page >

Jet munts 140 Xbl problem starting

Notices
Merlin Turbine Clinic Support for Merlin Turbines is provided in this forum

Jet munts 140 Xbl problem starting

Old 12-30-2014, 08:14 PM
  #1  
Hawkflyer
Member
Thread Starter
 
Join Date: Oct 2003
Location: Sydney, AUSTRALIA
Posts: 63
Likes: 0
Received 0 Likes on 0 Posts
Default Jet munts 140 Xbl problem starting

Hi I have a new 140 Xbl first few starts were ok and then had problems. I gave it back to our local rep who got it running ok. I picked it up and am still having the same problems. Our local rep is overseas on holiday so I can't contact him for a while.
what happens on start up it goes through the normal start cycle including pumping fuel but does not light off. Eventually you get the ign fail message.
The radio I am using is a jr dx9 but have also tried a spektrum dx18 just in case it is the digital throtle trim causing a problem.
Old 12-31-2014, 03:30 AM
  #2  
Jim Cattanach
 
Jim Cattanach's Avatar
 
Join Date: Mar 2003
Location: Larnaca, , CYPRUS
Posts: 2,140
Likes: 0
Received 2 Likes on 2 Posts
Default

Make sure your ecu battery is in good condition & fully charged. Also increase your glow power voltage by a couple of points.
Do not increase the glow power voltage above 7 volts.

Last edited by Jim Cattanach; 12-31-2014 at 03:45 AM.
Old 12-31-2014, 12:00 PM
  #3  
joeflyer
My Feedback: (47)
 
Join Date: Dec 2001
Location: Plymouth, MI
Posts: 2,926
Likes: 0
Received 13 Likes on 11 Posts
Default

It sounds like your ceramic heater may be shot. I had that problem on my M140 and had to send it in to have the heater replaced under warranty. If the heater is working you should hear a slight hum when you first initiate the start. Also if you put your hand on the case you should feel it get slightly warmer, and you should see the EGT increasing a few degrees. If that's not happening you need to send it in.

Joe
Old 12-31-2014, 01:50 PM
  #4  
Hawkflyer
Member
Thread Starter
 
Join Date: Oct 2003
Location: Sydney, AUSTRALIA
Posts: 63
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you,
will try these things today

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.