Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic > Merlin Turbine Clinic
Reload this Page >

Merlin 100xbl Not reaching full RPM

Notices
Merlin Turbine Clinic Support for Merlin Turbines is provided in this forum

Merlin 100xbl Not reaching full RPM

Old 10-15-2016, 02:31 PM
  #1  
Vettster
Thread Starter
 
Vettster's Avatar
 
Join Date: Sep 2007
Location: Beeton, Ontario, CANADA
Posts: 1,329
Likes: 0
Received 3 Likes on 2 Posts
Default Merlin 100xbl Not reaching full RPM

Hey guys.. I bought a used engine that will not goto 152,000 as its supposed to. I don't want to have to return it as its been a month or more, but I have only got 3 flights on it and its not pumping it out!

Max RPM is 145,500 The fuel pump is new. 7hr on engine. Good 7.4 lipo to run.

I called him and he said to make sure that the ECU was set to 152,000. It was set lower and I upped it.. but then why is it not hitting max rpm. Perhaps I didn't lock in the change I made? Did I miss something?
Old 10-15-2016, 10:15 PM
  #2  
Felix Barrao
 
Join Date: May 2007
Location: Zaragoza, SPAIN
Posts: 183
Likes: 0
Received 0 Likes on 0 Posts
Default

Note the PW of the pump at full throttle. Check in the run menu the "pump limit" parameter value. It should be at least 10% higher than the PW at full throttle. ( The PW will never exceed the " pump limit"), limiting it to about 10% more than max PW, make the engine run smother mainly with big pumps.

Im assuming that the EGT dont exceed the max temperature at full throttle, ( this could be a reason too).

Good luck,

Last edited by Felix Barrao; 10-15-2016 at 10:22 PM. Reason: Mistake in pw value
Old 10-16-2016, 05:41 AM
  #3  
Vettster
Thread Starter
 
Vettster's Avatar
 
Join Date: Sep 2007
Location: Beeton, Ontario, CANADA
Posts: 1,329
Likes: 0
Received 3 Likes on 2 Posts
Default

Thanks for the reply Felix! Gaspar has replied via email. I will try what he mentions and at the same time take note of what you have suggested. Much appreciated!

From Gaspar....

Hello Trevor,

First make sure that the radio is commanding full power. On the data terminal you should see “Run-Max” when throttle set to full, if you see “Running” then means that the 100% command is not sent, in this case re learn the radio.

If you see “Run-Max” but the engine don’t reach full rpm, keep the throttle at max for over 5 seconds, then you will see “Calibrating” and the ecu will increase the pump until arrive to maximum. If the engine has been run at lower setting, the ecu will take some time to adjust all the parameters again for new settings.


Gaspar

FYI Felix.. the temp never went over 550 if I recall correctly​

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2022 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.