RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   Merlin Turbine Clinic (https://www.rcuniverse.com/forum/merlin-turbine-clinic-376/)
-   -   MERLIN 160 Question (https://www.rcuniverse.com/forum/merlin-turbine-clinic-376/11630245-merlin-160-question.html)

raron455 06-14-2016 11:11 AM

MERLIN 160 Question
 
Hello, I recently purchased my First Merlin, a propane start 160, from another member, it was recently upgraded to a MK2 and has 58mins on it. I just finished the install in my Jet and have a problem. I set the radio function up, and got a green LED on the Fadec ECU. I then went to purge the fuel system, put the pump in manual, it came on ramped up, then stalled and gave an overload alarm. The reason is because the fuel valve Is not opening. I went into the test function, and manually tried the fuel valve, NOTHING, will not click, Neither will the Gas valve. I tried rotating the connectors in the ECU, still nothing, I then took a 4.8v battery and manually tested the valves directly, they click and work. I took my voltage tester and plugged it into the valve pins on the ECU and tried testing the valves again using the GSU. STILL NOTHING no voltage on the voltage checker, for some reason the ECU will not send power to either of the valves, is there something I am missing? The valves only have a red and black wire, the ECU plugs have 3 a -+- Manual says polarity is not a problem. I tried plugging the valves in every way possible, still nothing. Any Help will definitely be appreciated.

raron455 07-10-2016 08:17 AM

As an update, I sent the turbine and all components to Todd at dreamworks, the old ECU (fadec) was the problem. Updated it to newest xicoy version.


All times are GMT -8. The time now is 07:55 AM.


Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.