Notices
MRC Charger Product Support (i.e. Super Brain, etc) Tim Sandor of MRC/Hirobo is your host. Ask all your MRC questions here!

Help with Superbrain 989

Old 12-15-2014, 02:34 PM
  #1  
akm
Member
Thread Starter
 
Join Date: Mar 2005
Location: Hudson, NH
Posts: 62
Likes: 0
Received 0 Likes on 0 Posts
Default Help with Superbrain 989

I have a MRC SuperBrain 989 and when charging lipos it will charge until the voltage is 4.2v per cell then stop charging. The charger just stops and does not continue onto the CV mode.
Old 12-15-2014, 05:48 PM
  #2  
collector1231
Moderator
My Feedback: (1)
 
collector1231's Avatar
 
Join Date: May 2010
Location: A place in a place.
Posts: 4,197
Likes: 0
Received 0 Likes on 0 Posts
Default

First, make sure you're doing a balance charge. Second, it may just do that. My Dynamite Passport Ultra does that on some charges. If the charger is broken or at fault, the Venom PRO2 LiPO charger is the right way to go.

http://www.atomikrc.com/collections/...attery-charger
Old 12-16-2014, 05:41 AM
  #3  
[email protected]
Junior Member
 
Join Date: Jan 2014
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
Default

Hello AKM,

The 989 should switch into the CV mode after the CC mode has completed. When the CC mode is finished the 989 will beep and display the word "Trickle". The charger is not actually performing a trickle charge on the battery. This is the indicator that the CV mode has begun. When the full charge has completed, you will see the word "END" appear where the amperage is displayed. You may also consider the battery fully charged when the amp display reads 0.00.

Collector1231 is correct. A balancer should be used while charging a lipo battery. We sell one that you can purchase directly from us or through your local hobby shop called the Accutec Balancer and can be found here:
http://www.modelrectifier.com/search...w.asp?ID=11403

If you have any further questions feel free to ask or contact me at [email protected]

[email protected]
Old 12-16-2014, 03:34 PM
  #4  
akm
Member
Thread Starter
 
Join Date: Mar 2005
Location: Hudson, NH
Posts: 62
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by collector1231 View Post
First, make sure you're doing a balance charge. Second, it may just do that. My Dynamite Passport Ultra does that on some charges. If the charger is broken or at fault, the Venom PRO2 LiPO charger is the right way to go.

http://www.atomikrc.com/collections/...attery-charger
Thanks for the unsolicited sales pitch and a post that has nothing to do with the issue I am having. And no thanks on venom products. I will contact John at MRC for further help but I will post the results of our correspondence so the info may help someone else that may be experiencing the same issue.

Last edited by akm; 12-16-2014 at 03:37 PM.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.